PDA

View Full Version : No SubD ??? Please Help


9192
02-22-2008, 02:43 PM
I am a beginner, owning 6.5 ESS. I run XSI on my Macbook Pro 2.4 nVedia 8600GT 256 VRAM via Bootcamp.

Last month I followed Aaron's book XSI4 modeling the dinosaur. Everything worked fine. Until last month I modeling just a sphere (for the dinosaur eye), but I can not activate Subdivision for smooth model look by using (Numeric)+ key at all.

Is there anywhere I can fine the pull-down menu for activating Subdivision?

I have tried both external keyboard and the built-in on my Macbook, but none worked. I am thinking the reinstall XSI, but it would be a great help if I can solve this issue without reinstalling everything.

Thanks,

9192

CiaranM
02-22-2008, 02:58 PM
Hi,
I use a macbook also. I was surprised to find that the macbook does not have a numeric keypad, so does not have the associated + and - keys. In XSI, I had to use keyboard mapping to remap the subdivision keys to '-' and '=', which can be found next to '0' on your keyboard.
I also found it helpful to remap all functions that use the 'delete' key to the 'backspace' key, which on your mac is labelled 'delete'.

Hope this helps.

9192
02-22-2008, 05:11 PM
Thanks for the tips. I think remapping the key is great idea.
However, before this, I can use Function key (+) + to get Subd.
Now, although I used external keyboard, it still doesn't work at all. The Delete key works well.

9192

Ohmanoggin
02-22-2008, 06:31 PM
Not sure if this is of use...

You can set sub-D level by going to Property / Geometric Approximation.
Then on Polymesh tab, you can set Sub-D level for Viewports and rendering.

Ohmanoggin

9192
02-22-2008, 06:38 PM
Thanks

Look like it is a bug from Apple Boot Camp. A lot of people out there lost there Function keys and Del key.

9192

curbsidebandit
02-22-2008, 06:58 PM
Well, if you want to up rez your model without using the keyboard you can go into the explorer (8 key) and open up the stack for that object - geometry approximation - polygon mesh - subdivision and adjust the ‘OGL level’ and ‘Render level’ together - but this is a hassle to do all the time. I think CiaranM is right, and you need to look at remapping the commands for your Macbbook’s keyboard. I have a Dell M1710, and I had to remap those two commands to my up/down arrow keys since I didn’t have a separate numeric pad as a desktop.

If you want to just straight subdivide your model you can alt+right click your selected model and at the bottom of the list there is the subdivide option or you can, under the model tool bar, go to create - ploy. Mesh - subdivision to do the same thing. Once there you can adjust the slider to subdivide as much as you want.

Hope that helps you

curbsidebandit
02-22-2008, 07:02 PM
Oops, Ohmanoggin beat me to it.

Saturn
02-22-2008, 07:03 PM
you have to press Fn + F6 to activate the numeric key board.

9192
02-22-2008, 10:06 PM
Thanks guys.

Saturn, I did that so, but somehow, I don't understand either why it doesn't work. As mentioned before it used to work well with only Fn key.
I am not quite sure that I messed something up with XSI or not, because sometime I boot into Boot Camp, but sometime I got through Parallel and XSI always warn me that the clock setting is different than the clock in the key, and I might have problem with my license.
I hope I will not screw up so much that I ruined my license.

Curbsidebandit, Thanks for the explanation. It is very helpful. As beginner, I still learning and practicing XSI. It is great to know the trick. Particularly, now I have problem with my wrist and shoulder so I have to get the massage therapy once a week. Thus, at home I got Wacom Cintiq 12 inch so I can lay back on he couch and having fun with XSI (without keyboard handy). It is not the productive way but it help my shoulder. At least I have to leave with it until I die.

Thanks again for everyone's help.

9192

renderAHH
03-07-2008, 12:21 AM
if your using the querty keys like in maya, use the page up and page down keys to step up and down subd levels

CGTalk Moderation
03-07-2008, 12:21 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.