PDA

View Full Version : Blendshape Woes


AlanWeider
02-11-2008, 06:04 AM
I am attempting to complete a character setup for a short film in Maya 2008. I had nearly completed all of the blendshapes when I came to one shape that needed a bit more of geometry. I groaned thinking that I would have to redo a lot of work, then read in the help documents that I can make changes to the base mesh and then go to Edit Deformers -> BlendShapes -> Bake Topology to Targets. This would update the target meshes. Which it did. Problem arose, however, when I applied the blendshape to the base and as I tested it I was getting odd changes to other parts that were not affected in the target for that shape. (I am doing a "brow squeeze" shape. The nose is squeezing together as well). I figured that I could try and paint a weight on the blendshape so that it wouldn't affect the nose, but when I select the head I do not get all the blendshapes in the editor. Only the first.

This problem may lead into my next question. In addition to the crushing nose issue, I am also not able to get these blendshapes to actually blend together. If I have one on, no other will work until I turn it off.

Any thoughts, suggestions, etc. are greatly appreciated.

Thanks in advance everyone! :)

AlanWeider
02-12-2008, 06:08 AM
Ok I think I figured out why the blendshapes weren't "blending" together. When I created them I used the default deformation order when I should have used "Parallel." Question is now whether or not I can change the existing deformation types from "default" to "parallel" without reattaching the blendshapes all over again (I have quite a few blendshapes).

Anyone know? I can't seem to find it in the help documentation.

Thanks.

~Alan

CGTalk Moderation
02-12-2008, 06:08 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.