PDA

View Full Version : Wrap Deformer trouble in the knee


gtcable
02-05-2008, 08:07 PM
So I'm minding my own business just reaching the end of weighting my character. I've done the whole arms through upper torso and feet. When I'm working on smoothing things out in the knees.

http://gtcable2.googlepages.com/shorts1.jpg


When I turn on the high res version of my model and see this...


http://gtcable2.googlepages.com/shorts2.jpg


:scream: Evidentally I'm having a Wrap Deformer issue. :scream:


I tried altering the Max Distance setting in the WrapD. I can only seem to reduce the WrapD's influence. Higher values have no effect.

Now I realize that when I sculpted the shorts over the legs I extruded up inside the shorts and then back down for the legs. Then I simply duplicated the body and did a smooth poly (with soft normals). Grabbed the lo res and high res and did a wrap deformer.

Now I'm worried because I don't see a solution other than to start over and resculpt the knees without going inside. Then I'd have to do the smooth poly, rewrap, soft bind, weight.... ug I'm gonna be sick.

Someone please tell me there's an easier way.

gtcable
02-05-2008, 09:28 PM
Wouldn't ya know it!
I solved my own problem.

I was using a double knee joint. I just went in and made certain that the vertices were weighted identical for in inside of the pant loop as the outside. That brought everything in line.

It's a bit limiting. But I'll make it through.

CGTalk Moderation
02-05-2008, 09:28 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.