PDA

View Full Version : mental ray render


xn3ct
04-24-2003, 11:06 AM
ok i'll post the following image because it's easier for me to explain.

And now the problem: why is the interior of the glass black? i have spent an entire day doing tests, and nothing. i tried to change the shape of the glass, the thickness, apply different glass shaders, but nothing.

The objects are placed in a box that has a little crack in the wall, through which the light from outside enters.

Well, if you can help me i would appreciate it.

-xn3ct (eccentricity)

svenip
04-24-2003, 11:09 AM
looks like a refraction issue to me. what refraction index you have set on the glass ??

xn3ct
04-24-2003, 11:12 AM
the refractive index is 1.2

i also tried a range... from 0.3 to 2 but still nothing

svenip
04-24-2003, 11:14 AM
you can try to set the max refraction to 1 or 2 in the render globals

xn3ct
04-24-2003, 11:22 AM
can't find it, could u be a little more specific please?

another test. simpler.

wgreenlee1
04-24-2003, 12:49 PM
I'm gonna take a wild stab at this.......
Could it be that the reflection and refraction of the glass is reflecting and refracting the rest of the box of which is dark?
The only thing I might think that would prevent this is to add a ambient light and have it only affect the glass and not the rest of the scene......or maybe not......I dunno....:D

Ozren
04-24-2003, 12:59 PM
First of all, before rendering anything, you should read and examine basic principles of RT(raytracing), how light works, and how photons work.

Your glass is not absorbing enough light rays, in other words, you need to incresse the number of your ray bounces. It should eliminate the black hole thingy.

In Mray options try playing with Min-Max Ray's, Depth.
If you have GI tuned on, play with Min-Max reflection bounces also.

Good luck.

xn3ct
04-24-2003, 01:20 PM
<In Mray options try playing with Min-Max Ray's, Depth. >

By Mray options you mean Mrayrender globals? Could you be more specific?

jeremybirn
04-24-2003, 09:35 PM
In Maya, your trace depth is set in three places: in Render Globals under Raytrace Quality, in the Raytrace Shadow options in each light, and in each shader under Raytrace Options, Refraction Limit and Reflection Limit. To get more shadows (such as seeing a reflection of the wall shadow in the reflective ball) you'd need to increase shadows on both the light and in render globals. To get more refraction steps (you seem to have only 2) you'd need to check the Refraction Limit on the shader itself as well as number of refractions under raytrace quality in render globals.

I was just discussing the Maya renderer, I think there are slightly different labels on the MR Render Globals, but I can't check now.

-jeremy

xn3ct
04-25-2003, 01:17 AM
ok i tried raising the settings but the result is the same. that big black spot is still there.

values:

-- glass shader:

refractive index:1.2
refraction limit:9
light absorbance:1
refraction limit:10

-- point light:

raytrace shadows

light radius: 0.150
shadow rays: 10
ray depth limit: 10

-- maya render globals
- raytracing quality

reflections:10
refractions:10
shadoes:10
bias:0.100


And this is the result.

jeremybirn
04-25-2003, 01:21 AM
That's great! You fixed it! Now I can see all the way through the glass to the green wall behind it.

By the way, my monitor at work has a very different gamma than a PC at home, so you might have missed the difference... you sound like you're still calling an area "black" that I can see through in your attached image.

Now that your trace depth is fixed, you could increase the trasparency or decrease the reflectivity if you wanted to see more through the glass and lighting up that area.

-jeremy

jeremybirn
04-25-2003, 01:25 AM
By the way, it looks as if you turned up the "light radius" on some of the lights, and that made the image grainy. Light radius gives you soft shadows by simulating an area light, but it makes the image grainy unless you turn up the "shadow rays" to oversample the light.

If you turn the light radius back down to 0, then you can turn the shadow rays all the way down as well, and speed up your rendering alot.

-jeremy

xn3ct
04-25-2003, 08:32 AM
jeremy thank you for posting. but the truth is that the problem is still there. and when i say that i mean the black area on the front wall of the glass. if rendered correctly i should be able to see all the way through the glass to the incandescent cylinder on the back... but i don't... and that's the problem. i tried to rotate the camera and render other angles, but it is the same. the black spot is still there, no matter where i looked. i will tried to play around with reflectivity and transparency, but i seriously doubt they will fix my problem.

i'm growing increasingly frustrated...

floguyep
04-25-2003, 12:13 PM
Have you tried turning raytraced shadows off?

augustus
04-25-2003, 12:34 PM
Did you tried lowering light absorbace? Highly transparent objects like glass have low light-absorbance, almost 0.

LowEndFrequency
04-25-2003, 03:50 PM
Did you tried lowering light absorbace? Highly transparent objects like glass have low light-absorbance, almost 0.

I agree, since the black spot sort of tapers off on the side then its no longer a ray depth issue..... I would say the light absobance is too high.... also try a different glass shader if that doesn't work.

jeremybirn
04-25-2003, 11:59 PM
In addition to that good suggestion, try turning your Refractive Index to 1, and then values very close to 1, so make sure you aren't just looking at a refracted image of another part of the background.

In terms of this getting frustrating, be sure to test just small regions of the image while you adjust it, so you don't do any full renders just to see a small area. Also, if shadows aren't involved in your problem, turn off shadow casting on your lights until this problem is solved.

-jeremy

augustus
04-28-2003, 06:54 AM
You're using GI+final gather, aren't you. This can be your problem:

Orginaly posted by spacemunky to the Maya 5 thread:

photons will not pass through a transparent object in MR unless you give them a MR shader node which is not a very well documented procedure

Andrei2k
05-04-2003, 04:46 PM
Originally posted by augustus
You're using GI+final gather, aren't you. This can be your problem:

Orginaly posted by spacemunky to the Maya 5 thread:


Well is there somewhere where there is documentation on this? Or do you know the workaround procedure.......annoying if this is true....

stunndman
05-04-2003, 07:05 PM
yes, if i understand it correctly it's documented in About > Lights and Cameras > Light in Maya > Light in mental ray for Maya

the quote


No shadow shaders
When photon shading is enabled, for example either global illumination or caustics have been turned on in the mental ray Render Global Settings window, shadow shaders are not exported anymore. Otherwise light would reach objects onto which shadows are cast twice - once through the shadow shader and once via transmitted photons - resulting in incorrect illumination. Photons can therefore not mimic certain Maya features such as a depth limit on shadow rays.


somebody asked the same question on the mental ray mailing list recently - i recently recommended on the AW forum the same procedure as post number two - attach a mib_shadow_transparency shadow - that works but seems to introduce some incorrect light behaviour - here's the whole thread


I've tried this in both maya 4.5 and maya 5. I can't get transparant or semi
transparant objects to cast transparant shadows. It works fine if global
illumination is off, but as soon as I turn it on all my semi-transparant
object start casting fully opaque black shadows.

Since I can't imagine this being a mental ray issue, this must be something
about my settings in the renderer or in the transparancy settings of the
shader.

Anybody know what I can do ?



I might be wrong but I think that is supposed to happen. In order to get
the physically correct transparent shadows you have to enable caustics.
However if you just want simple transparent shadows just attach the
mib_shadow_transparency node to the shadow shader input of the transparent
shader. Set the colour and transparency to match the shader and the mode to
3 (all lights). That should do it.



> I've tried this in both maya 4.5 and maya 5. I can't get transparant or semi
> transparant objects to cast transparant shadows. It works fine if global
> illumination is off, but as soon as I turn it on all my semi-transparant
> object start casting fully opaque black shadows.

Without global illumination (-globillum off), transparent shadows are
handled by shadow shaders. If global illumination is turned on, they
become specular photon transmissions, and shadow shaders should not be
used because you'd get double light transmission. I would therefore
suspect the photon shaders on the transparent material. I don't know
the Maya shaders though.

Thomas

--
Thomas Driemeyer <thd@mentalimages.com> mental images, Berlin

stunndman
05-04-2003, 07:14 PM
the conclusio is actually quite plausible - any light passing through a surface is refracted (even if refractive index is 1) - and refractions are secondary rays handled by caustics (as are reflections) - a quick test seems to confirm that - one spot light and caustics turned on (that's not a hole in the surface - it's a lambert with transparency set to 1)

stunndman
05-04-2003, 07:24 PM
the image

viker
05-02-2004, 12:04 AM
Well try turning up the Max reflections and max refractions in MR general tab ! And max ray depth just to be sure !

here is a pic of how it works for me !

CGTalk Moderation
01-14-2006, 11:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.