PDA

View Full Version : Urgent: Shake 2.51 files down to 2.5


Grayson
04-23-2003, 12:18 AM
Is there anyway to get Shake files created in version 2.51 to open in 2.5? If anyone knows; it will save my life tonight.

dmeyer
04-23-2003, 03:35 AM
Not sure, check the shake forum at highend2d.com

Grayson
04-23-2003, 09:54 PM
I lived through the night....I found another way around the issue. :cool:

I checked the highend forum and didn't see anything that would apply to this. I'll probably ask them later. I know this board is a little faster; that why I posted here first.

But I still haven't found any way to get files back and forth between versions; if anyone knows if this is even possible lemme know.

beaker
04-24-2003, 04:04 AM
Read the "Shake2.51LateBreakingNews.pdf"

It says this:

Since version 2.51 introduces new proxy functionality, a script created in version 2.51 must be modified in order to load the script in previous release versions.

If a version 2.51 backward compatibility problem occurs, an error message similar to the following appears in the Console: error: script.shk, line 27: too many arguments for function DefineProxyPath
DefineProxyPath("No_Precomputed_Proxy", 1, 1, -1, "Auto", -1, 0, 0, "",1);
^
To correct this problem, do the following:
1 Open your script in a text editor application (for example, TextEdit, VI, etc.)
2 Locate the "DefineProxyPath" lines at the top of the script.
3 Delete the "DefineProxyPath" lines from the script. Example:
DefineProxyPath("No_Precomputed_Proxy", 1, 1, -1, "Auto", -1, 0, 0, "",1);
DefineProxyPath("No_Precomputed_Proxy", 0.5, 1, 1, "Auto", 0, 0, 1, "");
DefineProxyPath("No_Precomputed_Proxy", 0.25, 1, 1, "Auto", 0, 0, 2, "");
DefineProxyPath("No_Precomputed_Proxy", 0.1, 1, 1, "Auto", 0, 0, 3, "");
4 Save your script under a different name.
5 Launch Shake and reload the script.

Grayson
04-24-2003, 12:09 PM
Worked like a charm! That's going to help me out so much. Many thanks! :thumbsup:

You've got your self a free drink if you’re ever in Savannah GA.

ntmonkey
05-07-2003, 05:10 AM
Hiya,

I think I'm having the same problem too. However, my situation has a little twist. I'm trying to open a file using Shake 2.50 that was create on a Mac OS X Shake 2.51. I open the script, but no nodes appear. No errors show either. I also edited the script like Beaker said but still, no go. Is there a way to get this thing open? And will this be a issue creating something on the Windows Shake 2.50 and opening it on the Mac OS X 2.51?

Thanks in advance,

Lu

CGTalk Moderation
01-14-2006, 11:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.