PDA

View Full Version : HELP::: Displacement maps Zbrush 2 LW::: HELP


animatics
12-10-2007, 02:35 PM
Hi all, my fist post here.

I am working to learn how to apply Displacement Maps (DMap) generated on Zbrush to Lightwave(LW) objects.

I've seen some tutorials and i managed to do the trick...

My latest 'test' was to do an anatomic face from a mask.



This is my orignal object, the mask.

http://i153.photobucket.com/albums/s202/animatics/Foruns/A.jpg




This is my work on Zbrush (Sdiv 5, but read 7, cause i freezed the SubD lvl 4 in Lightwave object before export, because of the UV, i got afraid it got all messed up, maybe i did wrong).
http://i153.photobucket.com/albums/s202/animatics/Foruns/B.jpg

It could be better but its ok for testing... The problem is that at this level i can't have smooth strokes on Zbrush, because dabs start to space alot from each other, due to processing heavy mesh (1.280.000 polys) . By the way, any other way to solve this spacing, other then apply the strokes reeaaalllyy slow?



(Generated DMap: Contrasted for better visualisation and original object UV overlayed; outer points were down sized to center to avoid the edges of the map)
http://i153.photobucket.com/albums/s202/animatics/Foruns/C.jpg


___________________________________________________________________________



Now the problems start when i go and apply this Diplacement Map to that cute mask...

Instead of the shapes and the detail i had in Zbrush, looks like the geometry is too lazy to go where i supposed to... Whats my problem here? Expecting too much of Displacement map?

http://i153.photobucket.com/albums/s202/animatics/Foruns/D.jpg
Nodes well done i think: Texture with mip map off, UV appled. Luma to Subtract (0.5). Result to Multiply. Result to Scalar. Spot Info to Scalar. Result to Displacement.
(Render with Subpatch Lvl: 50 | 149.000 polygons)




Since i wanted results, i went on 'heavy' way. I exported the Zbrush Sdiv lvl 3, calculated DMap from 3 to 5. Went to Lightwave and rendered that heavy mesh with subpatch lvl 2 (149000 polys) with the new DMap apllied on. And it worked... ( now i could see in detail all those crapy bumps on the muscles fibers :P)

http://i153.photobucket.com/albums/s202/animatics/Foruns/E.jpg



Then i started figuring: Well the UV map hasn't changed much... only the geometry has changed... Since the SDiv 1 on Zbrush is no longer alike my original model in Lightwave, and the DMap is calculated based on SDiv1...

Then the words: 'morph map' came to my mind. I exported Sdiv 1, loaded on LW, put my orignal model on foregound and the Zbrush exported on background and executed 'BKGMorph'. Voilá, my model looks like Zbrush Sdiv1.

So now my DMap would be apllied to an object looking just like the Sdiv 1 in Zbrush... So there were more chances the DMap would work right this time.
Wrong... : \ It came out like this

http://i153.photobucket.com/albums/s202/animatics/Foruns/F.jpg
(SubD 4 , 156.160 polys) The volumes displaced correctly but the fine detail was lost :\



So i increased the Subpatch to 16 and this message came out 'Not enough memory for object Polygon Data'
My brave AMD 2200 was bleeding out but managed to calculate these 2.498.560 polys. But still, Fine detail is not so good has in the heavy mesh render...

http://i153.photobucket.com/albums/s202/animatics/Foruns/G.jpg

___________________________________________________________________________
= Questions =

How can i make sure that i won't have this happening again; aplyed DMap not looking like in LW? How can i make sure mesh goes where i want without having to use some heavy mesh objects from Zbrush on LighthWave and still getting all the fine detail?

Ty for replys....





___________________________________________________________________________

ranhell
12-10-2007, 04:29 PM
that nice i cant even get my displacements maps to show up i dont think im exporting a displacement map im just creating some nice detail and losing it all but thats ok because im getting exposed to the tools, any ways i dont have an answear for you. you are already a few steps ahead of me......

Booyar
12-10-2007, 06:09 PM
...
...hi, animatics
...
...dont know if you have seen this but:
ftp://ftp.newtek.com/products/LightWave/Trial/Videos/zbrush-nodes-aps.mov
...
...if that doesnt help maybe a dude called Proton on here can help (im sure he did the video tutorial). at the moment he's kicking out some amazing tutorials on nearly everything LW.
...
...i myself am looking to get into Zbrush (osx platform) to add detail to my models.
...sorry for asking but what version of LW are you using and do you intend to animate with your models once back in LW?.
...just wanted to know what i have to upgrade to so that i can use ZBrush and i would really love to learn about animating with LW models that have been ZBrushed...
...
...

animatics
12-10-2007, 08:34 PM
hi guys

Ranhell i had many problems when working on Z brush. First the file handling is not very intuitive, then steps to do the Dmap have some nasty tricks, easy but not intutive again. I dont know much about Zbrush. But i can manage to 'go there, make my s**t and get out' like Walter (http://www.youtube.com/watch?v=1kXOg23pGeA) would say :P

Booyar i have seen that tutorial for sure :P i love LW vid tutorials: the best. The guy on them as a very nice voice and a nice way to show things, and always goes a little further in the 'problem'. I'll look for that Proton, maybe he can help me.

LW9.0 i think. My intencion now is not to animate right away. I have 2 years of lightwave and i'm still a noob on modeling, and i dont know much about texturing. College doesn't leave much time for testing testing testing :7 So thats where i am now...

Learning to increse detail to a model, and then paint it its my exercise now :D

For animation i prefer now to spend time on drawn one. I think its better to learn the animation mechanics then a nice software that does the betweens for you. Also, looks like, to have a quality animation in 3D its hard, and you have to know a whole new world, and modeling and texturing are big enough for me now :P


But back to the topic of this thread. What i want to know is:

-Does the displacement map has limits? Or any map i apply the geometry will alwyas move according to that, and will look like Zbrush? What am i doing wrong? I think i might not understand very well the DMaps mechanics, about the way the map is apllied to the geometry.

-Wich way is better: SubD and freeze before going to Zbrush, ot this is huge mistake, and its better to Sdiv in Zbrush?

-Does morphing the orignal object to the lvl 1 Sdiv of Zbrush worked mesh is a mandatory step, before applying the displacement? I figured that out but maybe its a normal step.

Bonzodogboy
12-10-2007, 10:29 PM
i've found taht it is good to use displacement for basic deformation, and then normal maps and bump maps for teh details. faster render time and fewer polygons.
check out steve warner's tute, it rules.

animatics
12-10-2007, 11:36 PM
Well thats an idea. Thank you!

bobakabob
12-11-2007, 12:27 AM
You got a pretty good result with your first render, the displacements look almost identical imo though not surprising as you've turned the subdivision up to 50. I doubt you could do that on full figure model without memory problems. If you combine a normal map and bump map as Bonzodogboy suggests you'll get the finer details at much lower settings - Steve Warner got sound results at 10 in his tutorial.

animatics
12-11-2007, 01:19 AM
bobakabob

The depth maybe be sharp on the first render but the look how the feature dont match the Zbrush screenshot.

My english is not very good so, what u mean in: "Steve Warner got sound results at 10 in his tutorial." Waht u mean by sounf results? looking good results?



=Question=

Should i calculate the Normal map like i did for the Displacement: Subdiv1 to 7? Or, i do a Dmap for the big shapes, and then from those shapes i calculate a nomal map for added surface details?


But ok, i think i can take myself satisfied. You told to use Normal maps for fine detail and Displacement just for big. That will probably solve the problem i had next time.

Ty for all replys

bobakabob
12-11-2007, 08:30 AM
Yes, sound means 'consistent' / 'good' in this context.

To generate the normal map, take the Level down to the lowest you can go. Check out Steve's tutorial as there's good advice on creating a bump map in ZBrush. Good luck and post your results... they all look good to me so far :)

uncommongrafx
12-11-2007, 11:22 AM
This is where the aps system shines; using it and you have pseudo-microdisplacement in those areas you designate. Really helps to focus where you want your polys to be generated from.

animatics
12-14-2007, 11:25 AM
Thank you for all the tips guys.

Ok so im seeing Steve Warners Video, and im understanding a lot of things i didnt knew.
Ill post some better results later.

So after of days trying to get a nice normal map, i quited because all i got was bad results; miscalculated areas, instead of fine and sharp detail i get and smooth displaced detail, iamge is fuzzy in some areas.

So, i tryed the bump map tip. I increased detail of my 550 tris model in Zbrush, then with Projection Master and BevelShowMaterial i just did muscles fibers.

1-New object; 2-With displacement map, and bump map on color; 3-Rendered
http://i153.photobucket.com/albums/s202/animatics/Foruns/render_web.png
(Subdivision LVL:32 563.200 Polys)


I'm aware of the several problems it has: Faceted texture because of non-smooth UV(how can i put it smooth again?), some areas have sloppy bump paint, that red is looking really bad because i use Dmap tex to fast colorize(Any thing else, bring it on). I'll repaint the bump, now i know it works.


Altough i got some nice test results with the bump map; comparing to the first images i posted, especially the 2nd render, the bump doesn't look so striking, so material as that extreme displacement.

I'll study Steve's videos and i'll try to this with normal maps, to see if it can get better results.

By the way, can i use zmmaper to creat Bump Map? Or is there any way to create Bump map activating smooth UV's?

Greatz..

CGTalk Moderation
12-14-2007, 11:25 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.