PDA

View Full Version : Model goes haywire during rigging


wallyworld
12-03-2007, 10:27 AM
Hello lightwavers,

here's the thing.

I just modeled a cartoon-flamingo. About 1400 vert.
Then i textured it. All went well.

Then i started rigging it. But like after two hours of rigging, (already did the ik chains and assigned some weightmaps) i was too curious to change a bone rest length. I wasn't in bone editing mode. My model went all haywire.

Well, no problem i thought. I didn't save or anything. Closed LW, and opened the file again. And the model was still haywire. Really strange.
I checked my incrementfiles, and they were all haywire untill about halfway the files.
I'm saying it again, i didn't save a thing after the haywire.

So i just started from the clean model again. Put in skelegons. Went to layout. The whole thing.
At the end of my worksession, my rig was almost done again. I saved it and shut down the computer.

Then about 5 hours later, i went to open the file again on another computer: the new rig was also completely haywire, when opening it. Almost in the same position as the last time. Again, most of the increment files were as well. This time i didn't do anything stupid like change a rest length or anything.

I also can't find a logic until where the save files are haywire. It ends in different places the two times it happened.

I'm planning on just trying to make the rig one more time. But i'm afraid it'll go haywire again lateron. If not during animation.

Can anyone help me with this problem?
Thanks.

Wally

ps: image can be seen here http://forum.simplylightwave.com/showthread.php?s=&threadid=5268

T4D
12-04-2007, 10:11 AM
ok simple LW rigging Advice

Key all you bones at Frame zero ( always work at frame zero when rigging )
Test your poses at frame ...10 ( or whatever )

Also rest them as well. ( hit the r key ) but you should not need that if you work with skelegons ( it happens when you convert them to bones )

Now IF you just convert skelegons and play with IK setting etc you just need to remember to key the bones at frame Zero. all " should " be cool and working ?? ( good to work with auto key ON for most times but remember to switch it off for some things )

Sorry Not a member of simple LW so couldn't see your picture ...

Skywatcher
12-04-2007, 12:57 PM
Hey Wouter,

just rest your bones in frame 0 and you'll be ok ( the 'r' key ).
If you import a model with skelegons and convert them to bones and then you change the
parenting of the bones, then the points in the mesh have to be told.

greetz,

Yvan

wallyworld
12-06-2007, 03:18 PM
Thanks a lot for your help T4D and Yvan.
It didn't mess up this time.

bye

CGTalk Moderation
12-06-2007, 03:18 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.