PDA

View Full Version : snake skeleton issue. Urgent.


buentiempo
11-19-2007, 04:46 PM
Hi everybody,
Im new with skeletons and I have a problem, (and a deadline problem as well)
I have a snake with skeleton and a IK spline handle. I have draw a path and then I have attached the curve spline to the motion path. and add "flow path objetc" to add a lattice deformer around the curve.
The problem is: the skeleton seems to twist in some moments so the model flips around it.
I have try playing around with some values like limit rotacion with not succes at all.
Can anyone help me on this?
Thanks a lot in advance.

Celeste

arrow000
11-20-2007, 02:45 AM
Um... How big are the gaps in between your bones? Maybe it's too big for the turns on your curve? It's hard to pin point the problem without seeing it...

alec.tron
11-20-2007, 09:31 AM
Hiya...
to me it sounds as if you re having an up-vector evaluation problem... from your description though I have no idea if it s the SplineIK or the motion path that s causing it...
On the SplineIk what you have to edit is in the Advanvced Twist Controlls to define the way it evaluates it's Up direction, on the Motion Path it s in the attributes, try putting it on Follow and adjust your WorldUp setting to what you prefer / need.
c.

isoparmB
11-21-2007, 11:05 AM
If you can't solve the flow path object flipping issue while using the spline ik curve, you might want to consider doing a flow path object on the actual geometry itself. (if it's just one shot).

Detatch the snake skin, attatch the actual model to a motion path and do a flow path object.

CGTalk Moderation
11-21-2007, 11:05 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.