PDA

View Full Version : Joint orientation and pole vector problem


frix
11-12-2007, 09:34 AM
Hi,
I'm very new to the rigging process. I'm trying to do a simple rig for a mechanical creature.
It got six legs. For its legs I wanted to use ikRPsolver. Before I used the orient joint tool to get the same local rotation axes for each joint. Z should be pointing up.
After applying the ikHandle the pole vector of the rotation plane isn't pointing in the Z direction. When I then want to point it in the Z direction all my local joints are rotated. See the picture.

http://www.dm.hs-ulm.de/user/danneker/joint_prob.jpg

Thanks for your help!

shinyprem
11-13-2007, 05:27 AM
Hi..
Its not natural that joint orientation change once you apply the iK solver, as you are going to use the iK only and the joint does'nt matter.

Rgds,

frix
11-14-2007, 09:54 AM
Hi thanks for your reply.
I figured out, that the leg has to be a little bend before applying the ikHandle. This way the pole vector gets the wanted orientation. Of course once the ikHandle is applied and you want to chance the pole vector the local joints are going to be rotated with the pole vector.

For me it is important that the local joint orientation and pole vector have got one axis in common, because later on I want to be able to switch between IK and FK.

Remi
11-14-2007, 08:18 PM
You could leave the joints straight if you want and use the "preferred anlge" option. Rotate the joints in the direction you want them to bend, right click set preferred angle and the zero the rotations back to 0. Then when you add the IK it should be oriented the way you want.

frix
11-24-2007, 08:55 PM
Sounds great Remi, Thanks for the help

CGTalk Moderation
11-24-2007, 08:55 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.