PDA

View Full Version : Problem setting smooth skin weights to zero


loraxle
10-26-2007, 11:48 PM
I have a smooth bind skinned character. I have also applied a lattice to this mesh to fix some bad deformation at the knees. I need to set the smooth skin weights of these skin vertices to zero so they will only be deformed by the lattice. However, turning off normalization and setting these vertices' weights to zero makes them all collapse to the origin.

Any ideas on setting a vertex skin weight to zero without causing the vertex to move to the origin?

Thanks!

Gnimmel
10-29-2007, 09:01 PM
You don't want to set the skin weights to zero, but instead turn on `Freeze Geometry` in the lattice attributes. This "freezes" any verts or cv's which are affected by the lattice and stops other deformers from deforming them, but still allows the lattice to move them as you would expect.

Richard

Gnimmel
10-29-2007, 09:09 PM
I don't want to double post, but after posting a reply on this thread and going back to the main forum, this thread was showing 0 replys?

Oh well, it kept my original reply, this one might kick it up the ass to say 2?

loraxle
10-30-2007, 05:55 AM
Thank you!

CGTalk Moderation
10-30-2007, 05:55 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.