PDA

View Full Version : Import or open .obj


Kanga
10-03-2007, 12:19 AM
Out of max import into modo 301 as .obj works fine except the mesh is black. Applying a new material doesnt work. Apply smoothing and the colour lightens to the proper value. Check all over the viewport settings and sure it is something simple.

Anyone?
Thanx in advance
Chris

pd
10-03-2007, 12:40 AM
301 imports vertex normals. See whether deleting the vertex normal map(found under 'other maps') helps, if there is any.

A12
10-03-2007, 02:36 PM
Out of max import into modo 301 as .obj works fine except the mesh is black. Applying a new material doesnt work. Apply smoothing and the colour lightens to the proper value. Check all over the viewport settings and sure it is something simple.

Anyone?
Thanx in advance
Chris


Use the FBX plugin to export from Max 9. In Modo 301, just open the FBX file and your surface and UV maps, etc. will be intact.
*Note:
1) When exporting FBX from Max 9, delete any "MeshSmooth" modifiers and collapse any "Symmetry modifiers.
2) When exporting FBX from Max 9, make sure a material is applied to the object.
3) Finally, when exporting with the FBX plugin, in the "Conversion Method" section select "Add Fbx_root Node" (you can also adjust the import scale and orientation for the model in this section as well.
4) If you only want to export geometry, uncheck Lights, Cameras, etc.

Hope this helps, Cheers.

Kanga
10-04-2007, 02:55 AM
pd
Couldnt find that item as I am new to modo. Still searching. Thanx for the help.

Brent_3D
That worked just fine! Thanx! Would the same be true with export back to max for rigging and animating?

:) Very speedy replies
Cheerio Chris

A12
10-04-2007, 04:08 AM
pd
Couldnt find that item as I am new to modo. Still searching. Thanx for the help.

Brent_3D
That worked just fine! Thanx! Would the same be true with export back to max for rigging and animating?

:) Very speedy replies
Cheerio Chris

Yeah, When exporting from Modo to Max:
1) In Modo make sure you have the proper UV map selected for your object and its image maps (located on the panel marked W, T, M O). Select "T" for Texture and select the UV map name that you created.
2) Now, just save your object (save, not export) as an FBX file. You don't have to change the Sub-D's to polygons.
3) Once in Max 9, go to "Import" and import the FBX file. The file should load as a textured, UV mapped, polygonal object. Just add your modifiers and go.

*Note: Normal Maps do not attatch themselves during the FBX export, so once in Max just go to the Bump channel of your objects Material and load in a "Normal Bump" image. Then render and you should see your normal map UV Mapped with the rest of your textures.

**Special Note: When texturing in Modo remember to use "Save Image" or "Save All" or "Save All Images" in order to save your image maps that you created. Modo only saves geometry with the standard "Save" command.

Have fun.

pd
10-04-2007, 01:25 PM
pd
Couldnt find that item as I am new to modo. Still searching. Thanx for the help.

I've attached a screenshot. This is where it's supposed to be. Just delete it and everything should be fine.

Kanga
10-04-2007, 10:06 PM
pd
Yes indeed, there it was, and yes indeed it worked! Thanx mate. I wouldn't have found this on my own:).

Brent_3D
Thanx, copied this for when it comes time to export. Tried sculpting on both the .obj and .FBX and nothing will budge. Tried sculpting on a cube from modo itself and sculpting works like a charm. Will have to unwrap the mesh anyhow and would rather do it in Modo then max thats for sure. I like the sculpting in layers concept so will try that out. Wish me luck:).

And yes I am having fun.
Thanx again for the speedy help!
Cheerio Chris

A12
10-04-2007, 10:46 PM
pd
Yes indeed, there it was, and yes indeed it worked! Thanx mate. I wouldn't have found this on my own:).

Brent_3D
Thanx, copied this for when it comes time to export. Tried sculpting on both the .obj and .FBX and nothing will budge. Tried sculpting on a cube from modo itself and sculpting works like a charm. Will have to unwrap the mesh anyhow and would rather do it in Modo then max thats for sure. I like the sculpting in layers concept so will try that out. Wish me luck:).

And yes I am having fun.
Thanx again for the speedy help!
Cheerio Chris

1) For "Mesh" sculpting, double check your object scale by creating a default Modo cube (by holding Ctrl down and left clicking on the cube icon) in another layer to check your *.fbx or *.obj scale.
2) Double check your "Push" brushes "Offset" amount, which by default is usually around 20%, you can increase it to around 80% or 100% to ensure your ability.
3) For Vector Displacement. make sure your model has a UV map and a material and make sure you have the surface name or material selected in the material editor before creating a Displacement Texture (avoid using "floating point" at first, unless your GPU can handle it and try *.png image format for 4k textures).

Cheers

pd
10-04-2007, 11:14 PM
pd
Yes indeed, there it was, and yes indeed it worked! Thanx mate. I wouldn't have found this on my own:).
Hey, I'm glad it worked. Something similar was driving me nuts 2 weeks ago.

Kanga
10-05-2007, 06:40 AM
Hmmm. Sculpting still isnt working for imported meshes from max. Just tried a cube. Hope a uv unwrap will fix that:).

Checked the scale and indeed the differences were high. rescaling didnt do it yet though.

Cheerio Chris

A12
10-05-2007, 03:26 PM
Hmmm. Sculpting still isnt working for imported meshes from max. Just tried a cube. Hope a uv unwrap will fix that:).

Checked the scale and indeed the differences were high. rescaling didnt do it yet though.

Cheerio Chris

In Modo 301 for "Mesh" editing, have you turned the *.fbx object into a Sub-D surface and subdivided it at least one time before attempting to sculpt?
Also, ensure you have a "Sculpt Tool" (Push) and a "Brush" (Smooth Brush) selected with an "Offset Amount" of at least 20%.
Note: Once you export from Max your Model is now in FBX format, so more than likely it's probably an issue with your Modo "Sculpt Tools" set up.

Kanga
10-05-2007, 05:29 PM
Brent_3D
Yes I thought it might be a settings thing but meshes made in modo displace very well and they seem to have the same settings as my .fbx and .obj. Just unwrapped the head of the .obj (OMG what a super unwrap function, its a knockout:)). Everything is sculpting just fine on the head. Perhaps objects imported into modo dont have inate uv info. Whut th heck,... its working:thumbsup:.

Thanx again
Cheerio Chris

A12
10-05-2007, 05:44 PM
Brent_3D
Yes I thought it might be a settings thing but meshes made in modo displace very well and they seem to have the same settings as my .fbx and .obj. Just unwrapped the head of the .obj (OMG what a super unwrap function, its a knockout:)). Everything is sculpting just fine on the head. Perhaps objects imported into modo dont have inate uv info. Whut th heck,... its working:thumbsup:.

Thanx again
Cheerio Chris

Yes, in Modo UV's are the key. Watch out for working in layers in the Vector Displacement mode though. Their have been some bug related reports that haven't been resolved yet.

*Note: When working Vector Displacement and Diffusion Maps, stack the Vector Displacement on top of the Diffusion Map. Their aren't any reports on this but I have found that it makes Modo work much faster. If your Vector Displacement Map increases it's displacement when you add a Diffusion Map just hit the "Tab" key twice to get Modo to reset to the proper displacement offset.



Rock on!

Kanga
10-07-2007, 09:39 PM
Brent_3D
Thanx for the advice! Saved all your tips to notepad:thumbsup:. Been messing with unwrap and still picking my jaw up off the floor. Relax is a blast.

Cheerio Chris

CGTalk Moderation
10-07-2007, 09:39 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.