PDA

View Full Version : Weird Strange & Unusual Blendshape Problem-O.


mental
04-07-2003, 06:43 PM
heya, i've run into an unusual blendshape problem that sounds familiar at first but...

i'm working with a full body mesh and i'm blending between Sets for the facial expressions. i thought i had everything done but noticed an odd problem: if i tilt the head say 45 degrees to the side and dial up a facial expression, the face will blend as if the head hasn't been rotated (it acts as if the blend was global, except that the translation doesn't shift. it fails to recognize the orientation of the character.)

i made sure that the sources for the blend had their translations untouched. the blends were specifed as local and i made sure they were placed before the skin cluster, in the deformation order (they are also using parallel blender nodes).

is there something inherent to using Sets that would give me this type of behavior? also i used a Set rather than a Quick Selection Set, would that have any bearing on the result?

and here's a pic of my character's inputs (it's a bit messy, don't mind the texturing junk i was fooling with )... hopefully somebody can spot where i went wrong.

thanks
-mental :surprised

http://mywebpage.netscape.com/SoulJack3r/screen3.jpg

MDuffy
04-07-2003, 07:36 PM
Ack! That graph scares me!

Well, the behavior you describe sounds like it is caused by the blendshape solving after your skin cluster. Which blendShape did you throw to cause this error? Do you know how to re-order those connections?

And also, why do you have so many blendShape nodes in there? Why not just have one blendShape for all your brow and eye targets? Have another for face and ears. You could put all your targets for a piece of geometry in a single blendShape if you wanted to, but it is often good to break them up into a few main groups for organizational purposes.

Also you should name your ffds and other nodes more descriptively.

Hope this helps,
Michael Duffy
mduffy@ionet.net

mental
04-07-2003, 07:49 PM
thanks for the reply Mduffy.

yep the graph is a mess (it's a long story but i ran into a weird bug that wouldn't allow me to add blends to an existing folder. that was a day of head scratching right there, since i've done it a hundred times in the past, but not with Sets as i am doing with this project... the only way to get around it was to create a new blend node for each and every blend. ugh! so, yes it is messy but it works.)

now, when you say that a blend is solving after the skin cluster:

i set the blends to be parallel in deformation order and then placed them lower (before) the skin cluster in the inputs... wouldn't doing those two steps avoid having the blend solve after the SC? if anything... the blends are solving parallel to one another and before the SC. also if i drag the blend nodes above the SC in the inputs window they stop working all together.

thanks!
-mental

MDuffy
04-08-2003, 09:52 PM
It looks like your skinCluster and facial blendShapes in in the correct order. I think the tweak node needs to be at the very bottom below the blendShapes though. Also if the interface is giving you errors in adding blendShapes (it does that to me when trying to add inbetween targets) then you can use the MEL command instead.

Also I don't know why you have blendShapes in the texturing area, and you should be careful that they aren't overriding anything. I haven't done any texturing with Maya yet, but in theory you should be able to set up all your UVs, etc, and then delete history to bake it into the geometry (or some other node). Your final character shouldn't need that much history in the texture, should it?

Hope this helps,
Michael Duffy
mduffy@ionet.net

mental
04-10-2003, 10:13 PM
thanks for the help Mduffy. i really screwed up somewhere along the line so its probably best to start over from scratch and do it the right way. :rolleyes:

thanks again.
-mental

CGTalk Moderation
01-14-2006, 09:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.