PDA

View Full Version : shader problem with keys?


jenny077
09-29-2007, 11:41 PM
can someone please ceck this scene?

shader test (http://www.sendspace.com/file/9ufoy4)

the white shader is the original, the red is the duplicate. When i move the timeline, the red goes back to white?

___

I have done a short animated scene. I need to apply shaders to the geometry. I have noticed that when I apply the shader and move my timeline into another key the shaders are no longer applied to my geometry and also they are no longer in hypershade.

Is there a way to apply shaders to objects without having to do it inside every key?

with the hypershade issue, i started with one shader which I copied as the base for other colours. when I moved the time line into another key, the shaders all returned to their base colour?


thanks

Kako
09-30-2007, 03:02 PM
Do your shaders need to be animated? And have you checked the input connections on them?
'Cause there are lots of animCurves nodes connected to the shaders. Did you do this yourself or does it happen automatically when you create a material shader?

jenny077
09-30-2007, 03:33 PM
no, I just got the shader off highend3d and want to use it because I like the effect. I dont want it anomated, I just want it applied to my geometry which is animated (does ths mean I need the shader animated too?)


what do you suggest?

thanks

DrYo
10-01-2007, 12:38 AM
Just delete all of the animCurve nodes. Go to Hypershade, right-click the shader and choose Graph Network. Select all of the nodes that look like function curve graphs and delete them.

jenny077
10-01-2007, 01:16 AM
this part of shaders is new to me.
what might function curve graphs look like?

thanks

DrYo
10-02-2007, 08:24 PM
See attached image. The animcurve nodes look like graphs. Select and delete them.

You can also select the shader node and go to the main menu, select the command Edit > Delete By Type > Channels.

CGTalk Moderation
10-02-2007, 08:24 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.