PDA

View Full Version : How Do I Turn Off Light Visibility In Reflections In MR?


drossxyu
09-25-2007, 06:10 PM
I'm using standard spotlights and I'm trying to get them from appearing in the reflections of my object. I've tried:

- turning off the specular component of my light
- turning the visible flag to 'no' under the MR tab of the light's transform

The material i'm using is an MIA w\ a thick_glass preset. Perhaps there's an option in the MIA material that I don't know about that doesn't count lights as reflections?

-f

Ronald
09-25-2007, 08:01 PM
in maya 8.5 there is a slider that says something like like highlight /reflection weight in the mia material. that should do what you are looking for. if you are using 2008 this parameter is gone (the interface changed - it might be there somewhere though). if you find it in 2008 let me know.


hope this helps

ronny

Emil3d
09-25-2007, 08:35 PM
@drossxyu, more specifically, In the mia_material put Glossiness and Glossy Samples to 0

@Ronald, look more carefully around the sections, all atributes are still there, just scrambled a bit. I guess they probably thought that Mental Ray is so boringly easy and scrambled a little bit the places of some attributes to add some nerve to our lives:).

drossxyu
09-25-2007, 08:50 PM
Thanks for the info.. Unfortunately, I still would like my material to reflect specular highlights so turning the glossiness all the way down isn't going to do any good. I Guess I'm really looking for something on the light itself. I want certain lights in my scene to provide a specular highlight (or in the case of the MIA material, a specular reflection), but others to simply provide diffuse illumination. I want to turn off the appearance of the light ( the one that shows up in the reflection), but still allow it to provide illumination ( both direct / in-direct(photons) ). I know If I just have my lights emit photons and no direct light, this will be resolved.. but I want my direct light. I also know I can use a self-illuminated super-bright prop to provide the specular reflection I need, but I like the specular highlight the spotlight is providing for this particular scene...I just want to be able to limit which lights provide them.

-f

Emil3d
09-25-2007, 10:51 PM
Glossy samples = 0 then changing the Glossiness slider makes the specular highlights of the mia_material behave like Blinn. You will have all reflections and illumination preserved but only the reflection of the light source/s can be removed or subtle. The trade off is that you canít have blurred reflections. As for the different lights emitting specular, just turn off Emit Specular in the Attribute Editor for the desired spot lights.

drossxyu
09-25-2007, 11:35 PM
Thanks Emil3d, i'll give your first suggestion a shot but turning 'emit specular' off when using the MIA material seems to have no effect. It's treating the light like an object and reflecting it, regardless of whether it's emitting diffuse or specular.

Emil3d
09-26-2007, 12:24 AM
The test was made with Maya 2008 with mia_material



http://i111.photobucket.com/albums/n129/Emil3d/specular.jpg


and without specular


http://i111.photobucket.com/albums/n129/Emil3d/Nospecular.jpg

Ronald
09-26-2007, 12:51 AM
that seems to be new in 2008 because i am pretty sure this did not work in 8.5

ronny

Emil3d
09-26-2007, 01:47 AM
You might be right, Iíve been using MR for years but mostly with Maya shaders and nodes, I started to explore the MR shaders and the custom side of it only recently and I think I remember now this limitation. Well, you can try my first suggestion but that will treat all lights equally. You may need to use some compositing trick with layers to add the specular comming only from certain lights.

MasterZap
09-26-2007, 06:02 AM
The stuff that makes mia_material respond to the Maya "emit specular" / "emit diffuse" is new for Maya2008, yes.

If not on 2008, your best bet is probably the "highlights vs. reflection balance" thingy, which will remove the speculars if turned to 0, but not just for one light, for all lights.

/Z

drossxyu
10-03-2007, 08:42 PM
Ah, thanks for the explanation MasterZap. That explains why Emil3d's suggestion worked at home w\ 2008 and didn't work at work with 8.5. I thought I was crazy..

-f

CGTalk Moderation
10-03-2007, 08:42 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.