PDA

View Full Version : mia_portal_light error


djx
09-25-2007, 07:07 AM
I am experimenting with the mr3.6 mia_portal_light, trying to set it up as described in the docs. Everything seems to be working and rendering in render-view window.

But in the output window I get this error
PHEN 0.4 error: Shader 'mia_portal_light': Light direction must be 0 0 z

and this makes my render farm unhappy when I try to render a sequence. :sad:
Does anybody know what I might be doing wrong?

-- David

djx
09-25-2007, 07:30 AM
I think I found a partial answer.:curious:

I had hooked up my mia_portal_light to one of maya's area lights. I changed this and used a spot-light-area-light and I no longer get that error. And it renders faster and the fg looks cleaner. (So I guess it wasnt really working correctly before)

Does that sound right though? I thought that the newer maya area-lights were what we should be using now and that the older spot-light-area-light method was not as efficient.

Comments welcome.

-- David

Wolfganng
09-25-2007, 05:44 PM
well ive been trying to find out what the problem is, but the reality is I think that even though the error appears, the portal light still seems to work. At least I seem to be getting the effect. Will try the spotlight aproach and see what happens

Emil3d
09-25-2007, 08:46 PM
I think I found a partial answer.:curious:

I had hooked up my mia_portal_light to one of maya's area lights. I changed this and used a spot-light-area-light and I no longer get that error. And it renders faster and the fg looks cleaner. (So I guess it wasnt really working correctly before)

Does that sound right though? I thought that the newer maya area-lights were what we should be using now and that the older spot-light-area-light method was not as efficient.

Comments welcome.

-- Daviddjx, you are correct, according to the help documentation The method of using a spot light to create a mental ray area light requires higher sample levels and has known quality and performance issues. The recommended method of creating a mental ray area light is to use a Maya area light.As quoted this also has been my experience with area lights, however this doesnít seem to count when it comes to the portal light.
I just tried this on a simple cube with a window with a portal light. When spot light is used there was no error and it was a few seconds faster, however visually the result was identical. From what Iíve read from the forums, everybody gets the error with the area light but no problems were reported. You are the first one reporting a problem and luckily found a solution. Thanks for sharing:thumbsup:.

CGTalk Moderation
09-25-2007, 08:46 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.