PDA

View Full Version : excluding objects from ambient occlusion


gmask
09-25-2007, 01:11 AM
I have a scene with a reflective dome environment. I'm trying to connect the mr ambient occlusion node to the diffuse channel of some shaders but because of the dome it makes them very dark/ almost black.

Is there a way to exclude specific objects from the ambient occlusion. I could just composite the occlusion but I have run into problems with that here and there.

achoury
09-25-2007, 01:28 AM
I have a scene with a reflective dome environment. I'm trying to connect the mr ambient occlusion node to the diffuse channel of some shaders but because of the dome it makes them very dark/ almost black.

Is there a way to exclude specific objects from the ambient occlusion. I could just composite the occlusion but I have run into problems with that here and there.

hi
add a miLabel attrbute in your shape u want to exclude
select your object hit ctrl+a
add attributes, give it a name: "miLabel"
check: keyable
Data type: Integer
minimum: -5
maximum: 5
default:5
don't use (0-1-2-3-4) because some conflit with mentalray shader mode
enter the positive value 5 or negative value -5 in Id_inclexcl of mib_amb_occlusion
hope this help!
sory for my english
rachid

gmask
09-25-2007, 01:41 AM
hmm that doesn't seem to work.. I may just use the fg occlusion since there is acually a checkbox to exclude objects from the calculation but I would love to get this to work with ambient.

Would it be a bother for you to create a simple example scene of how this works?

djx
09-25-2007, 02:55 AM
gmask, it sounds like you need to set a non-zero max distance to stop everything being occluded by the dome.

As well, I wrote a simple tutotial about the self-occlusion setup.
Have a look here (http://www.djx.com.au/blog/2007/05/12/ambient-occlusion-with-milabel/) if you are interested.

-- David

gmask
09-25-2007, 03:03 AM
Thanks, what i didn't realise is that I have to add the miLabel to all objects that I want to have occlusion

mr Bob
09-25-2007, 03:16 AM
Ditch the label idea , make a lambert shader set all the vlaues to zero , alter the colour to white. Dont use a material override on your layer , just apply the occlusion shader to the geometry you want to show the occlusion, then just apply your white lambert shader to the rest. and dont be tempted to use a surface shader , they break render layers !

B

gmask
09-25-2007, 03:19 AM
Read first post... I don't want to composite the AO

The label feature kicks ass and totally solves the problem I was having.

CGTalk Moderation
09-25-2007, 03:19 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.