PDA

View Full Version : Particle in Fusion


AbhijitINDIA
09-21-2007, 12:08 PM
Hello All,
I have a problem in fusion. When I am trying to compose particle with any 3d mrg node, where the particle having region “Bezier”, the bezier is showing at one place in view whether the particle is generating from another place of view port. That’s why the particle is not visible in render also. How can I solve this problem.

1armedScissor
09-21-2007, 02:39 PM
Is it possible to post your composite or a mockup of it? Or even some screen shots demonstrating the probelm?

AbhijitINDIA
09-22-2007, 07:43 AM
I am giving you an example file.

shortcut
09-25-2007, 11:32 PM
Hi,

it seems there is an offset to the bezier type of emitter region. Could be a bug. All the others (bitmap, cube, sphere, line, rectangle) are positioned correctly in 3d space.

If you can't get the desired result with any of the working region types, you can try the following workarounds:

1. suggestion (I think it's the quick and easy one): Try to shift your emitter spline so that the particles are at the right position. In your example go on the emitter's region tab and change the x and y offsets to -0.5 . This should fix the particle positions related to the 3d geometry but you will still have your region spline off related to the particles.
2. suggestion: Build a bezier spline mask in 2d using a background tool with RGBA=1 and a polyline mask connected. The polyline has to have a thickness, so turn off "solid" and give the "border width" some value. Now you switch the emitter region type to "bitmap" and drag and drop the bg-tool there. The particles will emitt at the coordinate center.
You can edit the polyline only in 2d, of course. Plus you are restricted to the XY-plane on the emitter. So I would rather go for the 1. suggestion ;-)
cheers
marcus

CGTalk Moderation
09-25-2007, 11:32 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.