PDA

View Full Version : Final Gather Flicker


quasiagent1
09-13-2007, 09:01 PM
Hello everyone. I'm currently working on a short film (http://forums.cgsociety.org/showthread.php?f=224&t=520223) for the Strange Behaviour challenge, and I am using mental ray with final gather to render my scenes. Unfortunately, I am very new to final gather (and mental ray in general for that matter) and I am experiencing severe flickering when I render my scenes.

Unfortunately, the computer where I do all of my work is temporarily without internet access, so I cannot post any images of my settings yet.

I did come across this mel script >here< (http://www.highend3d.com/maya/downloads/mel_scripts/rendering/mental_ray/3751.html) and I will be trying it out, but I have no idea if this is the best solution.

Obviously, since this is a time-sensitive challenge the quicker and the more detailed the suggestions I can get the better :eek: Any help y'all can give me would be most appreciated.

royter
09-13-2007, 10:20 PM
for static scenes, you can bake your FG map,
in your MRrenderglobal node, choose render fg maps and render your scene from different angles.


as for animated scenes, try to raise your FG rays, if that doesn't work, raise your point density.

quasiagent1
09-14-2007, 02:21 AM
I did try raising the rays a good bit, and though that seems to help with the quality and with static object, anything that moves has sever flickering on it.

Again, since I cannot get my computer to connect to the internet, I have no way to upload a video of the flickering. I did, however, attach a couple of images. The after shot clearly shows less splotching, but if you look closely at the background, the rear wall has an odd look to it (almost like a watercolor filter in photoshop). This might be because I tried to mess with the min and max radius settings for FG, but I don't know.

Also, I have no idea how to alter point density, or even what that is. Any further help or hints you can give would be very appreciated.

royter
09-14-2007, 03:53 AM
point density has a default value of 1 in the FG options, raise it.

in maya 8.5 there is an automatic min/max radius option, turn it on.

quasiagent1
09-14-2007, 04:52 AM
Hmmm, perhaps I should have mentioned I am using Maya 7?

I don't see point density... anything under final gather... I'll look again. I can miss some pretty obvious things at times. Is there anything beyond this that I should be trying?

phix314
09-14-2007, 09:16 AM
Yea, 8.5 (maybe 8, dunno) has a few FG flicker reduction options, but from what I've read the only solution pre 8.5 is pretty severe, i.e. 1000+ rays.

And no, you're not missing them. Maya 7 has different options and handles FG a little differently.

grantmoore3d
09-14-2007, 01:41 PM
I think you're going to have to give us a bit more information about your scene...

1) What kind of lighting are you using?
2) What are some of your FG settings?
3) Mental Ray : Sampling?
4) Anything else?

The only realy way of reducing FG flickering that I've heard of, is to add lighting and throw raytraced shadows over the FG flickering areas... but I think that might be a little difficult for your scene!!

djpitha
09-16-2007, 08:47 AM
i did try some test. Point interpolation helps flickering.
Normally it set to 10 so i raised up to 4o it helps !!!

CGTalk Moderation
09-16-2007, 08:47 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.