PDA

View Full Version : Particles wont collide with geometry


Tom N.
04-02-2003, 09:58 PM
The scene is really simple and I can't figure out why this isn't working, I select my particleshape, then my geometry and go to Particles - make collide. But then when I play it and the particles emit into the geometry, they don't collide and they just go right through it. What am I doing wrong?

Any help is much appreciated

-Tom N.

augustus
04-03-2003, 06:38 AM
Did you checked dynamics reletionship editor? (or whatever its name)

Jozvex
04-03-2003, 06:58 AM
It sounds to me like you're emitting your particles from inside an object? Is that the case?

If that's the case, it's because of the polygon normals. The normals need to face the particles in order for them to collide.

alexx
04-03-2003, 08:39 AM
>>josvez: The normals need to face the particles in order for them to collide.

that is not really true. although it is a good idea to have the normals in the right direction maya can and does handle collisions with objects that have normals facing in the wrong direction (can quick check that with a default poly sphere and an emitter inside.. works perfect for me.. i think you *can* get problems sometimes but in most cases it works.

Tom: what kind of geometry are you using? nurbs or polygons?

if it is nurbs you might have to increase the tesselation factor in the geoConnector.. but that should only make collosions better and not enable them..

do as augustus suggested: check in the dynamic realationship editor if the surface is really connected to your particles as a collision object..

you can post an image of your scene.. that might help seing the problem as well (or post the whole scene)

cheers

alexx

edit: one last thought: do you have your playback settings to: "play every frame" if not do so :)

Hugh
04-03-2003, 10:55 AM
With regards to the normals issue - this is more of a problem when you're using soft body dynamics - I remembering spending a while trying to figure out why my dynamic ball passed straight through my ceiling (I hadn't turned the plane the other way up)

Jozvex
04-03-2003, 11:24 AM
Oh ok,

Yeah I know I've had problems where the answer was the normals, so I just figured you had to have them face the right way!

Tom N.
04-03-2003, 04:27 PM
hmm i've tried all of those things except for the normals issue.. I'll look at it anyways.. I made sure that the particles are emitting outside the objects and i checked the dynamic relationships editor for collisions.. maybe its just my settings for resiliance and friction on the collision? i vaired them up a bit but still nothing made a difference tho.. hmm i'll try starting over, thanks for all the advice!

-Tom N.

alexx
04-03-2003, 08:18 PM
hmm.. resillence and friction wont help in that case..

can you post a small example scene? that would help in bug hunting for sure..

cheers

alexx

augustus
04-04-2003, 06:42 AM
I select my particleshape, then my geometry

I don't know too much about Maya particles, but i think you should select particle object, not particleshape node.

Tom N.
04-08-2003, 06:29 AM
hey guys this is dumb but i restarted the scene and it all worked fine... thanks for the replies tho!

-Tom N.

CGTalk Moderation
01-14-2006, 08:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.