PDA

View Full Version : Rendering an Alpha Channel all white


dragonfollower
08-31-2007, 10:54 PM
Hi,

I'm currently trying to render out the following image as a .tga file with an embedded alpha channel:

http://img.photobucket.com/albums/v370/dragonfollower/Example3.jpg

The alpha channel currently looks like this by default:

http://img.photobucket.com/albums/v370/dragonfollower/Example1.jpg

I want it to look like this (like a "white matte pass" but embedded within the .tga file):

http://img.photobucket.com/albums/v370/dragonfollower/Example2.jpg

Is there a way to do this in XSI? My last 3D app was Lightwave and I seem to remember it rendering out an alpha channel like this by default. Any help would be great!

-Brian

Strang
08-31-2007, 11:55 PM
your alpha looks like an occlusion pass.

Sbowling
09-01-2007, 03:32 AM
I can't remember ever having to do anything special to get an alpha to show up correctly. If you use the show alpha option in the render region does it look like it should? It may be that you have a screwy setting somewhere, or there is a problem with the format you are rendering to.

Strang:

Yeah exactly! That's what I was thinking too. It looks like an occlusion pass. That's not at all what I'm wanting. I have Foundation so I'm compositing using After Effects.

Felipe:

Thanks for helping, though I'm not sure that would help as I have a LOT of materials in the scene. It would need to be on a more global basis I think.

Honestly it just seems weird that XSI can't render out a simple alpha channel of black and white to aid in compositing. I don't know, maybe I'm doing something wrong.

-Brian

Felipe
09-01-2007, 04:52 AM
You could use a Color_math_Basic node just before your material and check the "apply to alpha" option.
I attached an image with the render tree for you to make it clear.

I use XSI 5.11 btw.

Cheers,
Felipe

dragonfollower
09-01-2007, 05:10 AM
Strang:

Yeah exactly! That's what I was thinking too. It looks like an occlusion pass. That's not at all what I'm wanting. I have Foundation so I'm compositing using After Effects.

Felipe:

Thanks for helping, though I'm not sure that would help as I have a LOT of materials in the scene. It would need to be on a more global basis I think.

Honestly it just seems weird that XSI can't render out a simple alpha channel of black and white to aid in compositing. I don't know, maybe I'm doing something wrong.

-Brian

Brainsells
09-01-2007, 08:52 AM
You are using the Ambient Occlusion shader on a material somewhere. You should open the AO node and slide the dark color's alpha to 1. By default it's at 0, so it will be in the alpha channel.

Strang
09-01-2007, 12:33 PM
i think brainsells is right. the alpha slider of your occlusion node is at 0 by default which will affect your alpha channel

dragonfollower
09-02-2007, 09:58 PM
Totally right guys! That was it! I guess it's probably better to render AO on the pass level rather than connecting the shader to each material?

Anyway, thanks for the help!

-Brian

Brainsells
09-03-2007, 12:59 AM
Usually it's better to do it separatly so you have more control over the color/contrast.

If it's a background object, you can also bake the AO into a vertex map by rendermapping it and using the Map Lookup: Vertex_RGBA node in the render tree.

CGTalk Moderation
09-03-2007, 12:59 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.