PDA

View Full Version : Problem: PF stops at a certain frame


Laserschwert
08-26-2007, 08:27 PM
I'm setting up a rain-system, consisting of four events: The main event which includes the birth system with the rain-streaks coming down, two events for the colliding and spawning splashes on the ground, and one delete-event.

I've animated the birth-rate, so that the rain starts with few particles, grows denser, and the fades out again. When I have only the main event eactive and deactivate the splash-events, particle generation works just like I've animated the rate. But as soon as I activate one or both of the splash-events, the rain builds up as animated, but particle-generation stops abruptley at a certain frame, and doesn't slowly decrease as before.

I don't think I've surpassed the maximum particle limit, and caching only fills up to 90MB.

What to do?

Bobo
08-26-2007, 08:44 PM
I'm setting up a rain-system, consisting of four events: The main event which includes the birth system with the rain-streaks coming down, two events for the colliding and spawning splashes on the ground, and one delete-event.

I've animated the birth-rate, so that the rain starts with few particles, grows denser, and the fades out again. When I have only the main event eactive and deactivate the splash-events, particle generation works just like I've animated the rate. But as soon as I activate one or both of the splash-events, the rain builds up as animated, but particle-generation stops abruptley at a certain frame, and doesn't slowly decrease as before.

I don't think I've surpassed the maximum particle limit, and caching only fills up to 90MB.

What to do?

There is an ARTIFICIAL limit of 100K particles set in the System rollout of every emitter. If you reach 100K particles (which is easy if you have lots of spawns), the system will stop creating any more particles. The actual limit per Birth event is 10 million particles, and there is practically no limit to the number of particles in a flow if you use multiple birth events/spawns. But the first thing to check is the System rollout of the PFlow Emitter and make sure it is set to at least 10 000 000.

Laserschwert
08-26-2007, 08:49 PM
Wow, thanks for the quick response! It's working great now.

I didn't check the command panel, and tried to find a limit-spinner somewhere in the PF-view. I've somewhat remembered that the particle-limit was like 10 million, so I didn't bother looking any closer, but now it's a lot clearer. Thanks again!

OlegB
08-26-2007, 08:57 PM
tried to find a limit-spinner somewhere in the PF-view

The limit spinner can be adjusted in "PF-view" as well - just click on the first (global) event, on the title area. The proper term for "PF-view" is Particle View.

Thanks,m
Oleg B.

CGTalk Moderation
08-26-2007, 08:57 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.