PDA

View Full Version : particle emmision on collision event ?unexpected particles?


Black&White
03-31-2003, 06:00 PM
i wanted to make a boulder collide with a ground and on collision it should emit partilces. i folowed this process:

1-making a moving active rigid body collide with a passive rigid body undergravity.
2-Made a soft-duplicate of boulder and having its particles gole towards active boulder.
3-after setting up collsion events of soft boulder particles(InheritVelocity=0). I could see new particles genereted on ground when soft boulder is.

My problem is the motion of new particles generated on collosion. i slightly increased the inherit velocity on collision event. And sured that new particles will collide with ground plane in DynamicRelationship editor. And added some gravity to new particles.

The pupose was to make a real dust emision on hit, but why most of the particles move through ground plane(under gravity)?

Octagon
03-31-2003, 10:40 PM
check if the particles emitted on the ground plance are spawned _above_ the plane in the first place. try to use another proxy object for the collision, not the geometry you will render. offset the proxy coll. object just a little bit above your ground plance.

also check your collision settings on the geoConnector node to match the detail on the collision object. try to increase the default value of 200 if you think your proxy object needs to be tesselated in more than 200 triangles for the collision to be calculated properly.

also, make sure you do have assigned collisions of the new particleShape for the spawned particles and the collision object.

it's supposed to work this way.

matthias

mark_wilkins
04-01-2003, 12:31 AM
I've found that making a creation expression that negates the velocity and keeping inherit velocity at 1 helps with this.

Unfortunately, Maya does not allow you to set a negative inherit velocity setting (for some dumb reason!)

-- Mark

CGTalk Moderation
01-14-2006, 06:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.