View Full Version : Normal Mapped Handgun w/ shading problem.

08-20-2007, 05:07 AM
Hey guys, I was hoping someone could help me out with this normal mapping issue. When I smooth the normals on my low poly model in Maya for export to a normal mapping program, parts of the model have shading issues. The geometry is all quads in these areas, and geometry wise it seems to be good. It's just the regular soft normals effect. When I bake the normal map in xNormal (also tried in Mudbox with similar results), those shading issues get baked into the map as well. If I make the edges hard, it fixes the shading issues, but also eliminates pretty much all of the normal map info when the map is baked. I haven't done much hard surface modeling with normal maps, so I'm wondering how this issue is usually tackled.


08-20-2007, 05:34 AM
it could be some vertices that arent wielded togheter.

08-20-2007, 07:03 AM
****** edited ******

08-20-2007, 07:07 AM
Are you using .OBJ files with 3dsmax? The max's obj importer/exporter is a bit old and buggy. If you use it I recommend you to change to other format. Notice some formats don't support vertex normals ( like the LWO which uses a strange smooth group system ) or automatically averages them ( like the 3DS ).

Also sure you perform a collapse+reset XForm ( freeze transformations in Maya ) before to export.

If you use xNormal try to use the .SBM exporter, will give you the best accuracy exporting the vertex normals ( and also can export the cage projection ). My second favourite is the .ASE.
When you export it as .SBM sure you don't set the "smooth normals" options, because will average the normals and destroy your smoothing groups... just keep that option unchecked when exporting it ( and also in xNormal ).

Hope it helps.

08-20-2007, 08:37 AM
The verticies are welded together, so that can't be it. The transformations are frozen as well. I'm using Maya 8.5, and exporting the low and high poly meshes as .objs. The low poly with the smoothing errors is the mesh itself in maya, so I don't think its a problem with the export. I just selected the whole mesh and smoothed the normals, so it isn't using any smoothing groups besides that. Should I be setting hard edges to eliminate the smoothing errors? Because that seems to minimize the normal detail when I bake with hard edges.

Thanks for the suggestions, keep em coming. It seems like this would be a common issue on any hard edged models like guns.

08-20-2007, 03:40 PM
It's because of the "regular soft normals effect" as you put it. Simply put, you have too steep of an angle for a soft edge there, the effect you see in the normal map is the normal map trying to correct for it but it won't succeed. Either add a chamfer or harden a few edges (which will result in less-than-ideal normal maps for those areas and errors).

08-21-2007, 07:46 AM
Thanks for the help. With some tweaking the hard edges worked out well.

CGTalk Moderation
08-21-2007, 07:46 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.