PDA

View Full Version : Ik Handle giving my joints rotation values


ajsfuxor
03-31-2003, 07:08 AM
Hey y'all

Why when i apply an ik handle to a standard 3 joint arm setup, the joints, suddenly get rotation values?

svenip
03-31-2003, 08:10 AM
yes, that's what they are supposed to do. the rot values of the joints are driven by the ik solver now.

what did you expect ??

ajsfuxor
03-31-2003, 08:16 AM
hehehehe

I know that what they do.

OK...let me explain a little better.

Start with a fresh scene, create 3 bones, and then apply an ikRP solver. Then check the rotation values on the bones. They are still at zero...as they should be.

But on the scene i am working on, they are 'popping' and are roating into a particular position. Something that i don't want.

svenip
03-31-2003, 08:27 AM
ahh ok.

david here tried something, and this seems to be only happening with spline ik solver and auto simplify curve.

all the other methods don't jump the values.

ajsfuxor
03-31-2003, 08:37 AM
see, now as usual with all software, i cannot reprode the effect even myself. So there ya go, problem solved without any solution :scream:

Actaully, now that i am up to it, another quick question on doing pole vectors. When i apply the pole vector to the arm, the pole vector has to swith to a new position to point towards the locator. SO, how do i get it not to move the joints? Know what i mean?

EG, create the joints, create an ik, and then a locator, but put the locator in a random position. Now when you click on the ik handle, the round pole vector appears at the root joint, and shows you where it is pointing. How do you get your locator to match where that is pointing, so when you do actually apply the pole vector, it doesn't move the joints to aim at the locator (because it would already be aligned with the locator)

Thanks dude, appreciate it!!

svenip
03-31-2003, 08:40 AM
snap the object you wanna become the pole vector constraint to the elbow. then apply the cons. after that move it whereever you want

james THP
03-31-2003, 09:04 AM
hey fuxor,

after you create your ikhandle check in the channel box for the XYZ of the Pole Vector, snap your locator to the joint the ik starts from, zero out the transforms, then copy the XYZ values of the pole vector to your locator... voila...

:shame:


james

Flo
03-31-2003, 01:30 PM
this problem can happen , if eg. the `preferreed angle`is totaly wrong eg. is set on purpose in the wrong direction.
so, setting a new ` preferred angle` might help too....

MDuffy
03-31-2003, 06:28 PM
This can also happen if your arm joints and their rotations don't lie in a plane. Let's take an arm for example. If the axis the elbow joint is to bend on isn't exactly perpendicular to the plane formed by the shoulder, elbow, and wrist joints, then the IK solver will introduce some rotations into your joints in order to bring it into the plane of solving. The IK solver will also likely move the elbow joint to be in the plane it calculates for solving, though usually this movement is slight. Because of this behavior, we had to change our setup automation scripts to create the joints, align them, and apply the IK before we aligned controls to the joints. This way the controls would be moved to the adjusted positions of the joints, instead of the original position before IK was applied. We also took steps to minimize this movement by making sure our joints were in a plane before applying IK.

Hope this helps,
Michael Duffy
mduffy@ionet.net

CGTalk Moderation
01-14-2006, 07:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.