PDA

View Full Version : Question about UV Mapping and preventing stretch


Troll-Mage
08-13-2007, 09:20 PM
Sorry I am still quite new to this program, so these might be silly questions.

Creating buildings with doorways, windows etc.

In some sections I want to texture all four sides (interior/exterior) the same texture, I use "A" to select all and then "U" for unwrap (smart projections) to unwrap it in the other blender window for the texture file. The problem is there is always at least one face that is nothing more than a line and the texturing for it comes out all stretched out. Do I have to texture that face individually? Which I have been doing and ties in to the other question below.

Also for a grand hall type entrance, I want to texture just the interior and exterior front entrance faces with different texture files than the other walls. I select that face and apply the texture file, but it comes out stretched. I use the "U" unwrap command, but it locks up the program.

Thanks in advance

Michael-Williamson
08-13-2007, 11:32 PM
Did you mark any seams ? if you didn't, hows it going to know where to split?

go into edit mode and select the edge where you want a seam or split, hit ctrlE and mark seam, go back to uvface select and unwrap with u...

hope that's what you were after, I didn't think your question was too clear!

Mike

Troll-Mage
08-14-2007, 02:56 PM
Did you mark any seams ? if you didn't, hows it going to know where to split?

go into edit mode and select the edge where you want a seam or split, hit ctrlE and mark seam, go back to uvface select and unwrap with u...

hope that's what you were after, I didn't think your question was too clear!

Mike

Yeah, I have messed around with this before but never seem to get the same results as in the tutorials.

I tried again following this tutorial http://biorust.com/index.php?page=tutorial_detail&tutid=85.
I marked the identical edge seams as in the tutorial, but the end result does not match up (see below). I imagine there is a setting in my config that is perhaps off that may be causing the problem.

Under UVs pop-up menu
Layout clipped to image size is checked on
Quads Constrained Rectangular is checked on

Under UV Face Select...
I hit "A" to select all faces
I hit "U" and choose "Unwrap (smart projections)" - result is one face of the cube is still hidden and the texture on it is stretched out badily.
I reset
I hit "U" and choose "Cube Projection", all the cube faces are there, but now they overlap with only minimal (acceptable) amount of stretch. Though I would really like it if it came out as it does in the tutorial's step 4 image sample.

fktt
08-14-2007, 09:07 PM
dont use the 'unwrap (smart projections)' use the 'unwrap' that in the top of the list :)

ZanQdo
08-15-2007, 11:59 AM
In the UV Calculation pannel change Angle Based to Conformal, its way better for arquitectural models, now use the unwrap tool

joeedh
08-16-2007, 10:53 AM
BTW, blender has a relax UVs feature called "limit stich", its in the UVs menu I think. Or you can use the hotkey CTRL-V. The tool is interactive; it continually repeats itself until you leftclick; scroll the mousewheel to blend between the relaxed uvs and the original, and rightclick to cancel (of course).

Joe

brkn
08-16-2007, 02:24 PM
Um, that would be 'optimise stretch', not limit stitch :) Limit stitch is for stitching separated UVs back to each other.

joeedh
08-16-2007, 07:13 PM
oh damn it I always get the name wrong! :)

Joe

CGTalk Moderation
08-16-2007, 07:13 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.