PDA

View Full Version : Skinning problem


wamo
08-02-2007, 06:56 AM
hey guys,
sometimes when i start skinning characters,i have this problem:
when mirroring it doesn't mirror correctly,what's the couse?
i was wdering if you could answer.

E.K

Dimich
08-02-2007, 09:34 AM
Judging by your screenshot it might be several issues: your mirror offset didn't seem to be at 0, when it should be, since you modeled your character probably at x=0 symmetry. Another main issue is you need to make sure your model really IS symmetrical. Any verts that cannot find their pair on the other side of the model will be red. Some minor offsets can be overcome by adjusting the mirror threshold. 0.5 is the default, you can try adjusting it more, but if it goes past 1.2-1.5 you are in quite some trouble:(... In those cases I usually just fix the model. Another cause for the mirroring problem is non-symmetrical placement of bones. You need to make sure to use bone-tools/mirror-bones to make sure you skeleton is symmetrical. Most of these are obvious things, so don't think I am taking you for a begginer, I'm just trying to grab hold of all possible issues:) one more issue is also the need to reset x-form. Scaled matrix can cause some unwanted results as well as the vert positions are distorted due to matrix offsets. Hope one of these solves your problem:) Cheers!

wamo
08-02-2007, 02:24 PM
hey dude,thanks
it really works for me.

CGTalk Moderation
08-02-2007, 02:24 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.