PDA

View Full Version : Blend shape slide problem.


SheepFactory
03-27-2003, 07:49 PM
Hi Guys ,

I import two head models and create a blendshape between them. But when I move the slider the target head slides on top of the blend shape geometry. How do I make it so the head stays still when being deformed by the blendshape?

And i have the origin set to local. still have the same problem.


thanks in advance.

Ali

sp0rk3d
03-27-2003, 08:24 PM
it is mostlikely that you froze the transforms on the blendShape mesh.... the deformer needs some offset values in the transform node to offset the slide...

easy to fix:
move the center pivot on the blendshapes to an easyly i dentifiable vtx... ie top of right ear or tip of nose.... by hitting insert and holding v to point snap the piv there.... the point should also be one that hasn't been moved on the blendshape

next move the blendshape back on top of the original by snapping it (center piv should be on the top of ear in this case..)
to the same vtx on the target mesh... top of the ear...
freeze the transforms of both meshes and reapply the blend shape....

that should do it :)

isome
03-28-2003, 04:00 AM
interesting b/c i had the same problem w/imported heads. never quite figured it out and just recreated my blendshapes...:shrug:

SheepFactory
03-28-2003, 02:46 PM
Thanks spork , you are a lifesaver :beer:

kiaran
02-08-2004, 03:44 AM
I just recently encountered this problem as well. Thanks for the tip spork3d.

modi
02-08-2004, 04:45 AM
Originally posted by sp0rk3d


easy to fix:
move the center pivot on the blendshapes to an easyly i dentifiable vtx... ie top of right ear or tip of nose.... by hitting insert and holding v to point snap the piv there.... the point should also be one that hasn't been moved on the blendshape

next move the blendshape back on top of the original by snapping it (center piv should be on the top of ear in this case..)
to the same vtx on the target mesh... top of the ear...
freeze the transforms of both meshes and reapply the blend shape....

that should do it :)

:bowdown:

kiaran
02-08-2004, 08:33 AM
Ignore this post.

marcoslm
03-11-2004, 03:41 PM
First of all, thank you for your advice. My headache finished...uff
I was doing my facial animation with maya 4.5 and i had this terrible problem with slider...So i decided to make a test with maya 5.o ple and it worked very very well.

But the only problem now is the faces not symetrical. When i do de blend shape the vertices of the target face go crazy...Wooah...it is like an explosion....So i continue with my dilema...aarrghh
is there any way to resolve that?
Marcos from Brazil

:bounce: :bounce: :bounce:

CGTalk Moderation
01-14-2006, 06:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.