PDA

View Full Version : blocky painting at less than 100% zoom


pixel_streamer
07-23-2007, 03:20 AM
I blocked out a sketch today at 50% zoom. When I zoomed in to start some detail work, I noticed my sketch resembled something that looked like I had applied a find edges filter in Photoshop.

Can someone tell me what happened?

Thanks.

Jinbrown
07-23-2007, 09:28 PM
Not without more information.

Read this tutorial on my PixelAlley site to get an idea of what kinds of information to supply when asking questions.

How to Ask Corel Painter Questions in Forums Around the Painter Community (http://www.pixelalley.com/tips_and_tuts/how_to_ask_questions.html)

Also, if you can post a demo image to show us what you're seeing, it'll help.

.

pixel_streamer
08-03-2007, 03:56 AM
I was drawing while zoomed out, and was getting very jagged results. Please see the attachments

tomt
08-03-2007, 04:35 AM
I think you are seeing a paper texture. If you are using any brush that interacts with grain, (Pencil or Chalk for example) you can reduce it by adjusting the grain slider to a higher number. Also, you can reduce the appearance of the blockiness by decreasing the paper grain size in the Paper menu, it will give you a smoother appearance.

Assuming that you are using a pencil or chalk, this is the effect you are supposed to get. If you want to completely eliminate it, you can use the flat colored pen.

Zooming in or out isn't relevant as far as I can tell from your images.
This is just an issue of seeing more detail at a larger image size.

Jinbrown
08-03-2007, 11:35 PM
Hi,

I agree with Tom, based on the demo images you posted, particularly the larger one.

His suggestions are good ones, and we could supply you with more if you'd supply us with the kind of information we need.

Specifically, the exact name of the brush category and exact name of the brush variant you're using. Then we can give you more brush control adjustments that may help.

If you haven't already, for general kinds of information we need in order to be sure we give you the best answers, read the tutorial I linked above on how to ask Painter questions in forums.


Good luck!

pixel_streamer
08-04-2007, 10:42 PM
I know what a paper texture looks like.

What I can't understand is that the brush is stair-stepping when I'm drawing while zoomed out. You can see that especially around that tooth area in the enlargement. I drew a small "U" but was all wiggly.

Sorry you couldn't help

Per-Anders
08-04-2007, 11:02 PM
It's just the sampling interpolation method that Painter sues when zoomed, all that's happening is that to avoid slowing down it doesn't sample every single original canvas pixel at a point and generate an average pixel color, instead it simply skips pixels. Certain levels of zoom use a higher quality interpolation method to get around this or try to resolve this, however the inbetwee levels simply skip pixels or use a basic bicubic interpolation. Photoshop suffers from the same problems.

pixel_streamer
08-04-2007, 11:54 PM
Thanks for the helpful response.

Attached is a different example; Painter X same brush, no paper (captured blank paper) at different zoom levels.

Is there away I can tweak my brushes to help avoid this in the future? If there's no way around it, it's a moot point.

Thanks again.

Jinbrown
08-05-2007, 12:03 AM
Well, pixel_streamer,

We're certainly trying to help.

We're left to guess what you don't tell us.

What brush variant was it (by exact name)?

Did you make any brush control adjustments to that brush variant and if so, what adjustments did you make?

What Paper was selected at the time?

Edit: I was typing this post when pixel_streamer posted his last screen print showing the brush stroke at 33% and 100%, so forget this question:

What zoom percent were you using when the screen prints were made?

How close is your tablet to your monitor or other electronic devices? If too close, it can cause the cursor to jitter.

Speaking of Jitter, go to the Brush Controls' Random palette and see what the Jitter slider is set to. If it's above 0%, try moving it down to 0% and make another brush stroke with the same brush variant that was giving you trouble.


That's all I'll contribute to this thread until you decide to help us to help you... by giving us more info. If I knew the brush variant name and any brush control adjustments you might have made, I'd have been willing to spend time testing it to see if I could figure out what's going on.


I'd have been willing to spend a lot of time helping.


Good luck!

Improv
08-05-2007, 12:28 AM
Thanks for the helpful response.

Attached is a different example; Painter X same brush, no paper (captured blank paper) at different zoom levels.

Is there away I can tweak my brushes to help avoid this in the future? If there's no way around it, it's a moot point.

Thanks again.

Just curious why you use 33%. Why not use 100% ? Is there a reason? Do you use a smaller monitor?

Jinbrown
08-06-2007, 02:00 AM
Please see Edit in my last post.

Thanks.


Jin

pixel_streamer
08-09-2007, 04:24 AM
That's why I visually communicate; I have a tough time written, or verbally sometime, starting in the middle of the conversation and all. I appreciate the help!

To answer all of your question(s) starting with: "How close is your tablet to your monitor or other electronic devices? If too close, it can cause the cursor to jitter."

1.My tablet's a good 20cm from my monitor, so it may be too close. That may be what's doing it, but it looks like that proximity would affect the 100% zoomed version, too. Weird.

2. to reproduce the anomaly: (and about the brush)
Painter X upgrade (WindowsXP)
select regular 2b pencil from the Pencils catgory (no mods)
Basic Paper
8.5x10in, 125ppi white artboard
zoom to 33.33% (one of the preset zooms for clean low-res previews)
draw with light pressure
zoom-in to 100% to view work

This anomaly shows more if a blank paper is created, but still very visible with no mods. I created a 256col paper with nothing in the window, and the strokes were jagged then, too.

(screen-shots were at 100% when made)

Liquid Ink brushes don't seem to be affected; I use this workflow with a Liquid Ink variant I made with no problems at all. (drawing at 33%, then diving in for a little clean-up)

I work zoomed out so my brush strokes seem to appear more natural. On paper, I tend to use the entire surface. On my wacomI3 tablet, I tend to use about 3/4 of the surface when working.

Also, I tried capturing the brush stroke while drawing at the 33% size. When it's played back, at 100% zoom, it's jagged. Not so if redrawn while zoomed at 100%.

Thank you

Jinbrown
08-09-2007, 05:40 AM
I followed your steps and here's what I got (zoomed-out versions screen printed at indicated zoom percents):

http://www.pixelalley.com/demos/100_50_33_25_pct_zoom.jpg


Solution (or the best we have):

1. Go to Preferences > General and change the settings to match the highlighted lines in this screen print.

http://www.pixelalley.com/demos/magnifier_incrmnts_drw_zmd_out.jpg


2. Then, click the M key to activate the Magnifier tool.

3. Click with the Magnifier tool to zoom in and Alt/Option-click with the Magnifier tool to zoom out.

Don't use any zoom percent that is not divisible by 25 as it will display pixelation.

In other words, starting at 100% zoom, Alt/Option-click once to go to 75%, twice to go to 50%, and three times to go to 25%.


This is a known problem and, again, this is the best solution we've found to avoid pixelation in the display when zoomed out.


Jin

pixel_streamer
08-12-2007, 07:18 AM
Jin, thanks for reproducing that.

The reason I use 33%: I use shortcut keys to navigate, and I've adopted ctrl -/+ for zooming in and out, in the eight different programs I use.

As you can see the options you pointed out were ticked off, as indicated with the screenshot as of my patch for Painter 9.5

I'm not knocking Painter. I've been a user since version 3.1, and have seen a lot of good improvements. And I've also read each manual. (Thanks for the alt-click to zoom in pointer) But I hadn't noticed the blocky sketching before.

Someone on this thread (Per-Anders) quoted that Painter has the same glitch as Photoshop. But I'm a firm believer in one-upping someone faithfully. Can't we get around that PS problem and take Painter to another level? That would recruit just as many people as the wicked new real brush set!

Thanks you all for fixing the super-crash glitch, btw.

nubeslocas
09-07-2007, 09:34 AM
Solution (or the best we have):

1. Go to Preferences > General and change the settings to match the highlighted lines in this screen print.

http://www.pixelalley.com/demos/magnifier_incrmnts_drw_zmd_out.jpg


2. Then, click the M key to activate the Magnifier tool.

3. Click with the Magnifier tool to zoom in and Alt/Option-click with the Magnifier tool to zoom out.

Don't use any zoom percent that is not divisible by 25 as it will display pixelation.

In other words, starting at 100% zoom, Alt/Option-click once to go to 75%, twice to go to 50%, and three times to go to 25%.


This is a known problem and, again, this is the best solution we've found to avoid pixelation in the display when zoomed out.


Jin

Thankx! Very helpful! This is one of the things i didn't like when working with Painter.

CGTalk Moderation
09-07-2007, 09:34 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.