PDA

View Full Version : Paint weights problem


markovicd
07-20-2007, 09:55 AM
hi everyone i have problem with paintweights tool... i select object and i start painting weights... i click on 1st joint... i paint it as i want it to be ... then i click on the 2nd joint ... paint it to... and then i return to 1st one and it same as it used to be... why is this happening ?

mindsample
07-20-2007, 12:12 PM
Because the influences affect each other. You have to lock the weightmap if you want it to not be affected by changes to other areas of the chain.

scroll-lock
07-20-2007, 01:16 PM
mmm yes, it could be that, but infact sometime there is really a bug with the paint weights tool. That`s exactly what`s happening: You paint the influences of a joint after that you just switch to another one and back to the first /even without painting anything on the second one/ and then the first is all messed up. The last time it occured to me was when I removed one joint from the influences. Then I couldn`t paint a sh**. I had to detach the skin and add the joints again for that to work. And by the way I`ve experienced this bug in 8.5 but not in 8. I really don`t know another solution for that... Detach and bind again, that`s the only way I could fix it. If anyone knows why it`s happening and can confirm the same bug I will be glad to hear a workaround.

CGTalk Moderation
07-20-2007, 01:16 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.