PDA

View Full Version : subd rig allowed?


rISO
07-17-2007, 08:45 PM
hi everyone!! :scream:

i would like to know if there is an easy way to "extract" poly mesh from a subd char model.. or better, could i give an animator a rigged character in "SUBD" pls?
as far as i remember there is a way to anim char in low poly and render it in hi poly then..
am i wrong?? that's my prob..
any suggestion, please?? :shrug:
tnx in advance :bounce:

trancor
07-17-2007, 10:00 PM
Oh my no, imagine the smooth function done on a poly model, takes a little while to smooth at times right? Now image that happening every frame you render, every frame the model moves and is altered. Subdives zap your cpu power for animating.


I'd suggest converting the subdivs to polies before you rig. It would make for faster animating.

Modify > Convert > Subdiv to Poly

rISO
07-18-2007, 09:15 AM
trancor, tnx again and again 4 ur answers!
i see now.. but i think my problem is more tricky..

1.when i smooth the polymesh i don't obtain the same good result as converting it to SubD.. but also if i convert it to SubD to have my cute model and then re-convert to poly to rig it, i got some problem on the mesh, maybe 'cause of some parameters i check or i don't...
this is my problem...

2.is it possible that TSM dleted all the blendshapes i did, auto-rigging the character?

3.as i convert it to SubD i see a weird error on the mesh..
what could it be please?
i paste a screenshot just to show u better what i mean..

tnx a lot in advance and enjoy 3D time to all :scream:

http://www.damstudio.com/images/screenshot-05.gif

http://www.damstudio.com/images/screenshot-04.gif

trancor
07-18-2007, 07:01 PM
Hehe, that looks cool for the mouth on the subdivs, heh. But that means your faces aren't connecting but they are all on the ojbect. Try merge in the Edit Mesh pulldown because your subdiv is smoothing each face separate from the object. This should fix the lip problem.


For the poly smooth, there is alot more information in the subdiv model, so you can just go into the history on the smoothed model; up the devision count from like 1 to 3 maybe. And try changing your method to linear. And maybe change Devisions per edge perhaps.

rISO
07-19-2007, 08:00 AM
..yeah, in fact was a mesh problem, solved now with ur help :wise: few faces were separated and i solved just with a mergevertex with a correct value.. and.. also the smooth with those settings was better..
but, i got another question then :scream: how to simply animate a char in low poly and then render it in hi poly, please? :D

JorelLatraille
07-19-2007, 10:13 AM
to be honest i havent tried using a wrap deformer on a higher res mesh but i think it can be done... not to sure on the response time though, or the simpler option is just smooth it before you render ;p

rISO
07-19-2007, 12:42 PM
tnx again JorelLatraille but let me xplain my question better..
could i smooth character mesh, maybe change some texture, some material, after i've done blendshapes and rig and animation, and just then render it? :rolleyes:

ex:
i got a scene.mb with a rigged and animated character, in low poly, with blend shapes..
could i change some txture, material and do meshsmooth and then render? :bounce:

tnx in advance ^_^

JorelLatraille
07-19-2007, 12:48 PM
yeh m8, thats not a problem, as long as you have done the UVs before hand if bot just delete non-deformer history! If you have never done UVs before just ignore me cos you probably apply the material by selecting the faces in which case it wont make a difference either :)

CGTalk Moderation
07-19-2007, 12:48 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.