PDA

View Full Version : Depth pass and leaves


AngelDream
07-15-2007, 06:12 AM
Hi, I'm having an issue with the Depth pass in a scene with a tree and leaves. The beauty pass is ok, but the depth pass renders solid polys instead of leaves. Anyone can help me please? thanks

smaug
07-15-2007, 02:58 PM
you can put the leaves in another partition and use an override connected directly to the input parameter of the sprite node(or the diffuse node if you are using phong etc. with an alpha)

that should solkve your problem

cheers

AngelDream
07-15-2007, 03:06 PM
That sounds neat, but how do I use that override?

AngelDream
07-15-2007, 05:56 PM
Ok, this is driving me crazy! whenever I create an overrriding for a partition and add the Surface set, and then in the render tree add a constant node to the override, it propagates to all the passes! and i get all my passes matted in white i need some help please, thanks!

AngelDream
07-16-2007, 02:26 AM
Ok, I couldn't properly set the override... when I feed the overriding node with a constant node in one partition in a depth pass, the shaders on the beauty pass and the rgbamatte pass are also altered. However, I managed to finish this without using it. It would be great if anyone can point me to get this override working. I'm leaving the finished image below. I hope you like it. c'ya

CGTalk Moderation
07-16-2007, 02:26 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.