PDA

View Full Version : combustion RPF/render elements tutorials?


Slugger
07-11-2007, 10:46 AM
Hi

been fiddling with combustion(and 3dsmax feeding it with frames) for a while now, but I cant seem to get a good understanding of the rpf & render elements thingy, did read teh tut_13 that only helped a bit, didn't say that much on motion blur, render elements etc,

so anyone know of any tut for this(rpf/render elements), web or otherwise? specifically I'd would like to get a better understanding of motion blur applied within combustion with rpf's as source(did try yesterday and it didn't look good at all, getting kind of he same alias effect that I've been having trouble with previous(when Dof'ing with combust), mainly beacuse of not anti aliasing the motion/id part of the render elements, which is bugging me a bit that those options cant be set while setting rpf options when about to render, and render to elements takes just to much time(which i dont' have right now), and render motion only cant be used to plug into combust's rpf-motion blur can it? basically I dont' know whats going on..).


cheers,

k.

PiXeL_MoNKeY
07-11-2007, 02:39 PM
If you are using Combustion 4 you can use the GBuffer Builder to add/replace the velocity or other channel data. So render the velocity channel as you want with render elements and replace it using the gbuffer builder. Another option would be look at ReelSmart Motion Blur (http://www.revisionfx.com/products/rsmb/) from RE:Vision Effects.

-Eric

Slugger
07-11-2007, 03:36 PM
thanks PiXeL_MoNKeY, did try that just now, could n't get it going all the same, did render out w render pass(also rpf's(tried tga's also)), velocity, alpha, object ID & Z depth, added a g builder to teh original rpf sequence, replaced the original rpf's channels with the newly rendered ones, added a rpf m blur and nothing...when disabling the g builder rpf blur does blur but does so as I discribed earlier, very frustrating not getting this thing going,

whish there was a option to antialias when render to rpf when not using elements, the objects(characters) that needs slight motion blurring is in foreground and is totally separated from enviroment

cheers,

k.

thatoneguy
07-12-2007, 12:31 AM
There is a "filter" check box in render elements. Is that what you're looking for?

PiXeL_MoNKeY
07-12-2007, 05:25 AM
It is kind of hard to help without seeing some sample files. If you could zip up the rpf + the extra passes of a single frame and a workspace of what you are trying, then maybe we could be a little more help.

-Eric

Slugger
07-12-2007, 07:51 AM
thanks, thatoneguy, no the filter checkbox is ticked, knew about that one from searching/reading post on this subject,

PiXeL_MoNKeY, I cant really upload any of this work stuff since the material is not my own, but I can do sample scene at home with the same setup with simple objects, hold on a day or so and I'll see if I can get a sample uploaded(wouldn't surprise me if all things works just fine(rpf mblur) when I try this at home)

cheers,

k.

PiXeL_MoNKeY
07-12-2007, 05:22 PM
Slugger,
I did some checking and noticed that by default the Maximum Velocity for the GBuffer Builder is 1.00. From my understanding this clamps the velocity to this value. Try changing this value to something much higher (say 1000.0 or so) and try the RPF Motion Blur Operator again.

-Eric

Slugger
07-12-2007, 07:50 PM
aha!, so it just might have worked when I replaced velocity within the g builder, but I wasn't able to see the result, will try this first thing in the morning, many thanks!

cheers,

k.

Slugger
07-13-2007, 01:59 PM
PiXeL_MoNKeY, you were right it was that default setting that was way to low, cranked it up to 10 and the effect is clearly visable, but somehow I cant get the result that I want out of it, jagged edges, doing something bad but what, have the velocity rendering anti aliased that much I can see but when applied rpf-mblur get distorted around edges etc. I'll try a simple scene and see if I can get that uploaded somewhere,

cheers,

k.

CGTalk Moderation
07-13-2007, 01:59 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.