PDA

View Full Version : Z-Depth in 8.5


nester999
06-28-2007, 04:51 PM
Hello all,

I have been working with maya for about three years now, and one thing that has always seemed to evade me is getting a z-depth layer to properly render out.

In maya 7.0 I would hit the z-depth checkbox in the Render Globals, and nothing would come out (I was led to believe it can be viewed in the alpha channel which is the little white circle next to the rgb channel button in the render view).

Now in Maya 8.5, I can't even find the checkbox, but I've found a tutorial on deathfall which uses an environmental fog shader. Unfortunately when I apply it to my geometry, my renders do not reflect it actually working or getting applied.

I have never actually gotten a z-depth channel to work, and I still have maya 7.0 so if anyone has any workflow for creating depth of field that isn't created using Maya's DOF (too time consuming with possibilities for error) and utilizes After Effects as well I would be most grateful. Thanks in advance!

~E

lazzhar
06-28-2007, 05:09 PM
Just render to Maya iff file format and open the output in Fcheck and hit "z" to see it.
You can use custom z-depth shaders as well if you want

overEZ
06-28-2007, 11:10 PM
i'll give you two easy ways in 8.5: one easy, one easier

easy: assign a surface shader to all geo. out color = white. in render settings>render options>use environment fog. fog color = black. near clip plane = distance from cam to closest geo. far clip plane = distance from cam to farthest geo. Saturation distance = about half of far clip plane.

easier: select all geo in scene. create a new render layer for all geo. use a the Luminance Depth preset on that render layer. render.

coccosoids
06-28-2007, 11:13 PM
Thanks :)

...
..
.

nester999
06-29-2007, 07:23 PM
You are a god among men...unless you're a woman by chance. Either way, thank you sooo much!

nester999
06-30-2007, 04:27 PM
Sooo, I tried both methods, and with both processes (using maya software & mental ray) I just got all white silhouettes. The only thing I could think of was that my unit settings were either too small or too high, but upon messing with those, I still could not get any sort of gradient or diffuse on my objects. Is this a common problem? Do I need lights in the scene?

nester999
06-30-2007, 04:28 PM
I guess the problem was that I did have lights in the scene. Weird. Thanks again!!!

overEZ
07-03-2007, 12:06 AM
glad to help :)

Krash
08-05-2007, 08:27 PM
For those who wish to know, Z-depth does work. It's just the dumb render view window doesn't display or save it with your image. However, in you render globals under the common tab you'll notice a path and a file name at the top. Follow this path in fcheck and look in a folder called tmp. There you will find an iff file with the same scene name. Open this in fcheck and your z-depth is there. I'm not sure why they wouldn't put z-depth functionality into the render view window, but oh well...

Kinematics
09-02-2007, 03:12 AM
but from what i can remember. the zdepth function in the maya render globals does not produce a high quality zdepth right? Or anti-aliasing isnt supported or something. So anyway if we wanted the control of a camera depth of field with reasonable quality in maya without playing with the zdepth in maya.

We could use the methods spoken off by "OverEZ" right? Im gonna use DOP with shake and see how it turns out.

DrYo
09-02-2007, 09:03 PM
My limited knowledge of z-buffers tells me that using the native renderer z-buffer is more accurate than image-based techniques such as env fog. The renderer creates a floating point number for the z distance of each pixel. If you use env fog you are limited to 24 bits of accuracy.

Someone please verify...

CGTalk Moderation
09-02-2007, 09:03 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.