PDA

View Full Version : IK Handle problem... (newbee question)


lcatalo
06-03-2007, 10:28 PM
Hello,

First off all sorry about my Inglish but...
I need help with a IK Handle strange behavior in my Maya 8.5.
I have a leg with 3 joints. The hip, knee and ankle joints. When I create a IK Handle from Hip and ankle joint, after selecting the handle, and with the move tool, I can't make knee to bend. I canīt make any movements with IK Handle. I've alredy made a reset in IK Handle Tool but the problem remains....

I hope that I was clear in my explination...

Thanks for all

DruG
06-04-2007, 08:02 AM
Do you have Modify > Evaluate Nodes > IK Solver checked?

It`s also good to have "knee" bent before applying IK.

lcatalo
06-04-2007, 08:40 PM
thanks for the replay...
actually I have that option disable. But when I turned on I can only move de handle in X. When I try to move in Z and Y theres no movement...
It's very wierd...

thanks again for you time! =)

DruG
06-04-2007, 08:47 PM
Well, if you want IK to work you have to enable that option!

And I`m not sure about that X movement. Do you mean you can only move in X axis and no other?

Or do you mean that bones you`ve created are not bending?

lcatalo
06-04-2007, 08:56 PM
here some images to try to show you what I mean....


http://noticiasdamalta.blogspot.com/
http://bp1.blogger.com/_9mZWmuwRvTs/RmR7j5mU8eI/AAAAAAAAAAM/t4JryGXvMjE/s1600-h/Untitled-1.jpg


http://bp3.blogger.com/_9mZWmuwRvTs/RmR77ZmU8fI/AAAAAAAAAAU/DSY5mVY1Qcc/s1600-h/Untitled-2.jpg


http://bp3.blogger.com/_9mZWmuwRvTs/RmR8AZmU8gI/AAAAAAAAAAc/1xOoMlpmTMo/s1600-h/Untitled-3.jpg

DruG
06-04-2007, 09:39 PM
Can you send me that maya file, so I can have deeper look? ;)

lcatalo
06-04-2007, 09:45 PM
Yes... I will send you the file... Send by email?
Thanks once again for your time...

DruG
06-04-2007, 09:47 PM
yeah.

And hey, you can stop thanking ;) That`s what forums are for.

lcatalo
06-04-2007, 09:54 PM
mail send! =)

DruG
06-04-2007, 09:59 PM
Mail sent, problem solved! ;)

I don`t know why, but there was Degrees of Freedom X unchecked:)

So, again...


Select Joint and open Attribute Editor.
In Joint rollout check X at Degrees of Freedom.

And that`s it:)

Seems like you have to do that for every joint.


Phew... we could have spent whole night guessing ;D

lcatalo
06-04-2007, 10:05 PM
Hehehe
Quick and efficient.... A simple check unchecked! =)
Now I can continue my learning process and find another problems =)) hehehe

Thanks man! =)

DruG
06-04-2007, 10:07 PM
Can`t wait... ;)

good luck! :)

CGTalk Moderation
06-04-2007, 10:07 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.