PDA

View Full Version : Netrendering and Animated Noise


ddustin
05-07-2007, 09:13 PM
We are trying to netrender a scene where a piece of equipment is suspended over an ocean.

The Ocean is constructed of a plane with a noise modifier applied.
We are animating the noise to try to liven the scene a bit.

The problem is when we netrender the scene, the animated noise jumps unpredictably between frames. The rest of the animation is fine.

As a test we are rendering all the frames on one render node (as opposed to having multiple slaves). It appears the issue is not present while rendering on one machine (after rendering approx. 10 frames).

All maps are located on a single network drive with the correct unc path.

Thanks in advance for any advice.

David

scrimski
05-07-2007, 09:29 PM
What about rendering the animated map via the material editor and replace the procedural with the resulting bitmap sequence. Will need some HD space, but won't flicker and will render faster.

DanHibiki
05-07-2007, 09:38 PM
We are trying to netrender a scene where a piece of equipment is suspended over an ocean.

The Ocean is constructed of a plane with a noise modifier applied.
We are animating the noise to try to liven the scene a bit.

The problem is when we netrender the scene, the animated noise jumps unpredictably between frames. The rest of the animation is fine.

As a test we are rendering all the frames on one render node (as opposed to having multiple slaves). It appears the issue is not present while rendering on one machine (after rendering approx. 10 frames).

All maps are located on a single network drive with the correct unc path.

Thanks in advance for any advice.

DavidTry using a point cache modifier on top of the noise. Make sure to save the cache on the network or use "include maps" in the net render dialogue.

ddustin
05-08-2007, 02:31 PM
I tried both options (Point cache and include maps) but the issue is still present.

The interesting part is it is only present in the first few seconds of the animation, after that it is OK.

I am not sure how to render it out via the material editor.

Thanks for the ideas.

scrimski
05-08-2007, 02:33 PM
Click you way into that map and rightclick->Render(if I remember that right).

safe05
05-17-2007, 05:30 PM
exactly. the reason this is happening is because the Noise map uses random functions to create it's appearance. Typically, these random functions rely on the computers internal clock to get a random value. So, different computers = different results. That's why you're getting jumping effects. Each computer is calculating the noise effect differently. Rendering out the map before hand and using that will solve the problem.

ddustin
05-17-2007, 05:43 PM
Eric,

Thanks for the idea.

Are you talking about rendering the entire map from an overhead camera as grey scale then aplying it as an animated material or is there another way?

David

safe05
05-18-2007, 12:19 PM
similar to what scrimski said. in your material editor, go down to the Noise map's level, right-click and choose "Render." This will allow you to render out the map to file. Good luck :)

CGTalk Moderation
05-18-2007, 12:19 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.