PDA

View Full Version : Texture Emission -> Particle color


SheepFactory
03-12-2003, 08:36 AM
Hi Guys ,

How do I get the Texture emission attributes -> particle color to work?

I assigned a Jpeg to a lambert and assigned that to the particle color attribute and checked the inherit color checkbox. And add the rgbPP and opacityPP as the manual suggests But when I playback the particles dont inherit any color , they are still grey.

Am I doing something wrong?



thanks in advance.

Ali

alexx
03-12-2003, 09:32 AM
you have to connect your file node to the appropriate slots ofthe emitter of the particles..
you find them at the very bottom in the attribute editor of the emitter

cheers

alexx

SheepFactory
03-12-2003, 09:34 AM
I did that and checked the inherit color checkbox.

still no love :\

SPENEN
03-12-2003, 09:44 AM
What are you trying to do? Din't really understand that =)

,.-'`SPENENī'-.,

SheepFactory
03-12-2003, 09:47 AM
I am trying to get the particles to inherit their colors from the texture.

alexx
03-12-2003, 09:52 AM
have a look in the file..

zip file (http://bigott.gmxhome.de/pics/colParticles.zip )

cheers

alexx

SheepFactory
03-12-2003, 10:03 AM
Thank you alexx.

i was middle mouse dropping the texture on the texture emission color attribute , it appears in order for it to work you have to do the connection in hypershade :shrug:

alexx
03-12-2003, 11:15 AM
MM dragging should work.. be sure to check the button beneath the field in the AE of the emitter that sais:
"use"

otherwise you just have the connection but it does not evaluate it :) (dumb behaviour :)

Reza_82ir
03-14-2003, 03:43 AM
Hi Guys
Is this matter you said about "Texture Emission (for POINT Particle) " ,working with "Blobby Particle"?
If don't worked with "Blobby",Please tell me methods :)
----------------------------------------------------------
Thanks

mark_wilkins
03-14-2003, 03:57 AM
If you can get it to work with hardware-rendered particles, you can get it to work with software-rendered particles by doing this:

make a particleSamplerInfo node.

Connect its particleColor attribute to the color attribute of your material, then assign the material to the particle object.

Should now work fine.

-- Mark

Reza_82ir
03-15-2003, 11:11 PM
Thanks Mark
Can you more Ditails?

I can't Emitted texture by blobby particle with software_rendered
Thanks;)

Saurus
03-17-2003, 11:12 PM
Can this be done using sequence images. I want to take a animated sequence of a ghost and use particle to dispurse the final few frames of the of the ghost. Would I also be able to use alpha?

saurus

alexx
03-24-2003, 03:54 PM
yes

cheers

alexx

CGTalk Moderation
01-14-2006, 04:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.