PDA

View Full Version : The "Limit" of Particle Flow (strange bahavior)


lehmi
04-24-2007, 10:28 AM
Hi I'm currently setting up a massive scene. I've got around 8 flows already which are rather complex as I'd say (each with atleast 6 Events) and Particle flow is starting to behave pretty strange.

It's still rendering and correct and visible in the viewports but when I go into the particle view and try to move nodes around he resets their position once I release the mouse button.

Also, I'm not able to change the order of Objects within Events.

Is this a familiar problem? Or am I doing something wrong? Too many flows?

I'm almost finished, but I think i'll need another 2 flows and I don't want particle flow to crash on me during the end of the project!

Can you give me some tips and advices? Did you ever happen to have problems like that (nodes not movable?)

thanks for your help

PsychoSilence
04-24-2007, 12:14 PM
i have similar problems with massive pflow scenes concerning the moving of events. but it never crashes, i think the reason over all is more a lack ram etc. then a bug inside of flow... concerning the order changing thing i guess itīs just dead slow because flow needs to calculate alot. maybe try to turn of the particular flow during significant changes. at least thatīs what i use to do. or set the update mode from "complete" to "foreward".

kind regards

anselm

lehmi
04-24-2007, 01:52 PM
ok thank you.

Well it's all fine if it's still working when I'm rendering... I'll test it at home where I have 2 GB and check out if that's the problem...

I could change anything even if I turned off all events... so it doesn't seem to be a problem with computation.

thanks,
alex

bobweb
04-24-2007, 03:56 PM
I am facing the same problem as well in a current project with a complex particle setup. It does not seem to be a matter of ram, since the strange behaviour can be reproduced even with two simple Flows, when they are placed with a long distance to each other... I do not have a solution yet, hopefully somebody knows... I am using Max8 SP3.

bobweb
04-24-2007, 04:08 PM
I have just found a more or less satisfying answer in the Orbaz forum by Oleg B. :

Q1. I have a complex scene with many PFlows, and I've noticed a bug with copying & pasting events within PView. Pasted events are placed in arbitrary positions and not under the mouse cursor. This problem seems to occur when there are many events inside PView.

Q2. I have a complex Particle Flow and the Particle View refuses to let me organize the events the way I want. When I drag an event to a new location, it snaps back to where it was. Since I can't put the events where I want, I have a disorganized mess with connection lines going everywhere. Where do I turn off all this auto-snapping nonsense?

A. This is a known issue with Particle View, and it happens when you have a lot of PFlow events spreading too wide in Particle View. To resolve this problem, try to delete the far-most events on the right side of Particle View (if the spread is vertical then the far-most events on the bottom part of Particle View).

Once you delete these events, the copy/paste/move operations should come back to normal. Try to place the events no farther on the right (or the bottom); occupy more or less square area of the Event Map.

PsychoSilence
04-24-2007, 04:55 PM
my assumption concerning a lack of ram was referring to the quote:

Also, I'm not able to change the order of Objects within Events.

the rest is a known and common issue with the view.

kind regards
anselm

lehmi
04-25-2007, 09:59 AM
thank you bobweb. I'll try this out and see if it helps!

superhypersam
04-25-2007, 07:37 PM
Its a known Pflow/3ds max bug,

place your flows in a general square shape, this solves the ui issues.

cheers


oops I was already beat too it

CGTalk Moderation
04-25-2007, 07:37 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.