PDA

View Full Version : Feet Sliding with Aux. Pivots?? Ideas??


Redsand1080
03-31-2007, 03:49 AM
I am attempting to set up an easy way to animate feet for walks using aux pivots grouped under handles...but my feet are slipping. My current set-up is the one I saw demonstrated on the videos on the MB site...I'm sure many of you have seen them. I have one aux pivot on the ankle and another on the foot(or more accurately, the toe) and I have them both grouped under one handle on the toe. But when I try to animate this in a walk the feet don't seem to stick to the ground.

Has anyone had this happen? I've tried to cancel it out using aux. effectors but that doesn't seem to do the trick either. Even when the effectors are locked and keyed at 100% I am still getting movement. Any ideas as to a solution? I'm sure others have experienced something similar...I just haven't figured it out yet.

Thanks! :thumbsup:

GiantG
03-31-2007, 09:20 AM
Hi.

Check if on your Foot ReachT and ReachR is turned on.
If you want to use the Aux Effector's correctly you must turn these off.

cheerz

Redsand1080
04-01-2007, 09:53 PM
It still doesn't seem to be working right. Do you know any good way to get the feet to lock down while using aux pivots to allow you to rotate from the back of the heel and the toe? It just not seem to be working for me. It's strange that they don't address this on the website at the end of their video. Maybe I'm just dong something wrong?

Anyways...any more ideas would be great!

Thanks. :thumbsup:

Redsand1080
04-01-2007, 11:01 PM
ya know what...i think i might have figured it out. i think it was because i was just setting keys with the 's' short-cut instead of explicitly telling MB to set an IK key only. it's wierd though...because the weighting on the feet was 100% towards the IK chain. i was doing pose-based animation though...setting poses for contact, passing, down, up, etc. for a walk-cycle, so i wasn't actually rotating the feet myself each time by hand...but instead letting the pre-defined poses dictate their positions for me. does that sound about right?

eddieellis
04-02-2007, 07:27 AM
i know this has already been said, but the reach and pull needs to be turned off on all other feet control points other than the one you are using, otherwise one will over ride the other.... once you control the feet with one pivot, you need to plot out of control sets, then plot back in using the next pivot point... and so on...

for extra control, flaten the curves in the fcurve editor

Redsand1080
04-02-2007, 10:39 AM
ahhhhhh...you know what...now I see what you're saying. I did some more research and found out that the ability to set an IK key in the key controls window automatically sets the selected pivot as the 'master pivot.' It actually goes and sets the reach t and r for that pivot to 100% for that keyframe and sets any other pivots in the foot to 0 for you and keys them at the same time. So by setting the key to an 'IK' key in the key controls window...I am doing exactly what you guys are talking about, I just did not know it. Cool stuff.

Thanks a lot. :thumbsup:

CGTalk Moderation
04-02-2007, 10:39 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.