PDA

View Full Version : q: errors with simple Save As actions


gaggle
03-06-2003, 11:26 PM
Why would some simple actions sometimes fail? I have set up a bunch of actions, each one just a simple Save As, where it saves the current image as a .tga file to a specific name. Hit the button, and there ya go..

The people using this system likes it a lot, and I avoid incorrectly named textures, but sometimes they just.. fail..

It faults out with an "Error saving, file in use" error.. I think that was what it said.. beh, I'll be sure to write it down the next time someone experiences it. Usually the next time you hit the button it works as it should though. The longest this error has lasted is about 7 repeated clicks on the action button before it went through. It just seems pretty odd, and I was wondering if others perhaps have had similar experiences?

singularity2006
03-07-2003, 03:17 AM
ur script has a slight flaw. It's trying to "save as" when it should be doing "save." When you try to "save as" and save as the same filename as the original, it's kind of like eating yourself while ur still alive. Just do a "save" instead a "save as" and all will be well in the world. have fun. :wavey:

gaggle
03-07-2003, 03:52 AM
Ah, sorry about that, I guess I forgot to mention that it's not saving to itself :)

The files are .psd files, but Maya doesn't eat those directly. Thus the small action, it saves with the proper filename and format at the click of a button. Or at times seven clicks, as it is.

Thanks for the response though, I can see how my question seemed logically flawed with that tiny "saving to different format" piece of information missing :)

CGTalk Moderation
01-14-2006, 03:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.