PDA

View Full Version : Multiple shape emitter emits along spline


NeoGeniX
03-21-2007, 03:26 PM
I've been searching and expirementing for days for a solution but I'm kinda clueless.

The thing I want is a TP Multiple Shape emitter that emitts its particles along a spline.

I tried some examples from bonkers.de and the exact thing I'm looking for looks like this: http://www.bonkers.de/tp/scenes/tp_movealongspline2.mov

I've experimented with the scene and replaced the emitter with the multiple shape emitter but it won't work.

Can anyone help me? (btw I have pretty much zero experience with xpresso)

Srek
03-21-2007, 04:51 PM
Please check the TP Presets that come with R10 (alternatively load them and their documentation from the MAXON website). They include a Multishape Emitter preset as well as the Move along spline preset. Both work just fine together.
Cheers
Björn

NeoGeniX
03-22-2007, 04:57 PM
Hi shrek, thanks for your reply.

I know about the presets and I've experimented and fiddled with them for hours. But my lack of xpresso knowledge limits me a bit. I cant seem to get it working. Do all the xpresso nodes of the 2 presets have to be in one window or can they be in a seperate xpresso windows. Like an object that has 2 seperate xpresso icons behind it in the object manager.

I will post a project file tonight on how I am trying to combine the two.

Srek
03-22-2007, 07:03 PM
There is no need to even open the XPresso editor, let alone directly combine or modify the setups.
Just use the Preset Objects as they are.
I think you somehow got it wrong as to how they work. The presets can make working with TP as simple as with every other object or for example the old particle system. The main intent of them is for the user not having to cope with XPresso at all.
If you want Particles to follow a spline, add the preset, drag and drop the spline in the according linkfield of the preset and press play. The rest is only some parameter fideling to make the particles behave as you like it.
Cheers
Björn

NeoGeniX
03-23-2007, 12:57 PM
I seem to have got it working!

Somehow a combo of the tp follow spline and tp multiple shape emitter and fiddling around with an example scene made it work.

Thanks for the replies!

CGTalk Moderation
03-23-2007, 12:57 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.