PDA

View Full Version : Char. Retargeting: Knees don't rotate!


ConSeannery
02-20-2007, 09:03 AM
Hi,

I am trying to retarget a mocap driven skeleton onto a 3D character in MB 7.5 Extension 1.

The results look pretty messy withouth tweaking in the character settings. When I play around with Reach, Offset and Pull values I am able to get pretty close to where I want the retargeting to be. However the knees remain an unfixable problem. They remain stiff no matter what I do and it looks like she is walking with peg legs. The strange thing is, that when I use the "Inverted Joints" option in MB 7.5 the knees suddenly start rotating IN THE RIGHT DIRECTION! lol I have no idea why. But even with the knee inversion the rotation is far from being smooth.

I have a similar problem with the shoulder joints. They never rotate the arms down when retargeting, but remain in kind of T-Stance position. This is not so much of an issue since I can easily fix it by using "Reach" for the Upper and Lower Arm, but still I have no reasonable explanation why the shoulder rotation is not transferred properly. I even tried to retarget between 2 almost identical skeletons of the same size and still the same shoulder problem.


Do you know what the problem could be? I attached a screenshot of the Knee problem. The yellow skeleton is the source, the other one of course the target character.

Im really thankful if one of you guys could help me out of this problem!

Bye!! :-)

mkapfhammer
02-20-2007, 04:37 PM
con,

in your character settings> retargeting> actor> motion reduction, do you have anything checked on?

i'd also check the character definations. sometimes you'll find the auto-characterization confuses a shoulder/clavicle with the upper arm.

ConSeannery
02-21-2007, 01:44 AM
HI,

actually I don't have an actor in the scene so motion reduction won't help me and I didn't check anything in there either. The source skeleton is a reconstructed skeleton right from the Mocap software ViconiQ and imported with a special motion builder plugin.

I didn't use auto-characterization. I mapped all joints manually into the respecitve fields in the character definition, because the bones weren't names according to the MOBU naming convention. Is it that what you mean?

I should also note tha the source skeleton is no in T-Stance while the target skeleton is.
Maybe this causes trouble?

bclark
02-22-2007, 04:59 AM
yes the non tpose is an issue, you need the two skeletons to start in the same stance as close as posible to each other.. T stance, arms out strait etc.. or it will not work as you expect. pose the skeletons in to a good T pose by hand then characteriz it agian.

mkapfhammer
03-01-2007, 10:23 PM
I didn't use auto-characterization. I mapped all joints manually into the respecitve fields in the character definition, because the bones weren't names according to the MOBU naming convention. Is it that what you mean?

Yes. Just wanted you to check if you had all the bones mapped correctly.

I should also note tha the source skeleton is no in T-Stance while the target skeleton is.
Maybe this causes trouble?

bclark's suggestion is right on.

However the knees remain an unfixable problem. They remain stiff no matter what I do and it looks like she is walking with peg legs. The strange thing is, that when I use the "Inverted Joints" option in MB 7.5 the knees suddenly start rotating IN THE RIGHT DIRECTION! lol I have no idea why. But even with the knee inversion the rotation is far from being smooth.

Check to see if the target skeleton has negative values on its rotations prior to retargetting. What app is your 3d character coming from?

ConSeannery
03-02-2007, 12:32 AM
The character is coming from a Poser to DazStudio (then exported via COllada plugin) and then into MB...and it should end up in Maya.

I will post again tomorrow or the day after, because right now the motion blending is not finished yet. So the retargeting still has to be done. Maybe this time it is working better since the motions are slightly different.

Later,


Julian

CGTalk Moderation
03-02-2007, 12:32 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.