PDA

View Full Version : Flattening 2 layers....mode's don't stay!


Denart
01-31-2007, 01:38 AM
THE SENARIO:

You have 3 layer

LAYER ONE:
A photo texture set to vivid light

LAYER TWO:
My painting set to multiply

LAYER THREE:
Flat background set to normal

Now, when I'm on the vivid light layer and I flatten it to the bottom mulptiply layer (ctrl-e) how do I still keep the vivid light effect in the end result?

It seems whenever I flatten 2 layers, it only keeps the bottom layer's mode effect (which was multiply in this case)

Thanks!

TheNeverman
01-31-2007, 03:41 AM
I think you need to use 'merge layers' instead of 'flatten'.

Denart
01-31-2007, 04:13 AM
nope, they do the same thing...

merge layer = ctrl E

merge layer is the technical term for 'flattening'

but thanks ;)

Ian Jones
01-31-2007, 05:04 AM
This is just a guess, I have't tested... but I'm thinking it depends on what is your currently active layer. Notice when you merge layers the one you had currently active is the one which everything merges into. Try merging into the topmost layer.

Datameister
01-31-2007, 06:43 AM
Sorry, but it can't really be done. The reason makes sense, if you really think about it. Blending modes require different ways of calculating the colors of the pixels. There's no way for Photoshop to mix two different methods in one layer; that isn't logically possible.

However, you can always just group the layers (ctrl-G). That'll make organization easier, though the file size won't get any smaller.

Denart
01-31-2007, 03:12 PM
Sorry, but it can't really be done. The reason makes sense, if you really think about it. Blending modes require different ways of calculating the colors of the pixels. There's no way for Photoshop to mix two different methods in one layer; that isn't logically possible.

However, you can always just group the layers (ctrl-G). That'll make organization easier, though the file size won't get any smaller.

this sounds legit. I'm glad this is settled. heh thanks man! :D

Ian Jones
01-31-2007, 04:40 PM
You can always Ctrl+a, then Ctrl+shift+c to copy across all visible layers. That should do the trick for you.

Datameister
01-31-2007, 09:37 PM
Good point, Ian. I forgot to mention that one. I used to find Copy Merged useless, but I use it all the time these days...now that I'm not so pedantic about my layer setups. :D

leigh
01-31-2007, 10:40 PM
Switch off all the other layers and use the Merge Visible option. This retains the effects.

Datameister
02-01-2007, 05:35 AM
No, that won't always work. Try, for example, creating a Color Dodge layer and a Color Burn layer (with different content in each) over a colored background. Merge Visible doesn't allow you to make one layer both brighten and darken the underlying pixels.

mattclinch
02-04-2007, 04:34 PM
You can only merge down layers with blending modes other than 'normal' onto the normal layer below that they are affecting.

In your case, you could ctl + e your multiply layer down to your normal base layer, then do the same to your vivid light layer.

Alternatively you can shift + click. Select the layers you want to merge using shift + click and then merge with ctl + e. This will collapse from bottom to top in the same way.

BlueFlare
02-04-2007, 09:54 PM
It seems whenever I flatten 2 layers, it only keeps the bottom layer's mode effect (which was multiply in this case)

Why the need to flatten them?

lricho
02-05-2007, 03:07 AM
another thing you could try is ctrl-alt-shift-e
It does a flatten all visible layers into the currently selected layer, but doesnt actually flatten the image (does that make sense?)
So i'd suggest making an empty layer on top, have that selected, then ctrl-alt-shift-e

CGTalk Moderation
02-05-2007, 03:07 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.