PDA

View Full Version : Never "Save As Copy"?


Dario D.
01-27-2007, 09:22 AM
Is there a way to tell Photoshop that I NEVER want to Save As Copy? So often, when I save files, I have to manually remove the word "copy" from the filename, and considering how much I use Photoshop, this gets *seriously* annoying, as I've never once in my life wanted to save something as a copy.

Is there some way?
Thanks.

BlueFlare
01-28-2007, 04:50 PM
I'm using CS2 for Windows and it never ads the word copy, the related box is also not checked. Can't remember why others have that problem, but try to search for the word copy in the Photoshop section only and make sure you select "search titles only". It will come up with several threads related to your problem.

Dario D.
01-28-2007, 08:36 PM
Thanks for the tip. I did a search, but none of the other threads where people complained about this had a solution. They just had to deal with it :sad:

diffx
02-08-2007, 11:29 AM
I understand what you mean.. it's really annoying :/

No, I don't want the word "copy" in my filename!

Neil
02-09-2007, 04:18 PM
I know what you mean, and its weird because sometimes it happens and sometimes it doesn't. I think it depends on what version of PS you use, but since every computer I sit down at has a different one, I've lost track.

SylvanMist
02-09-2007, 05:13 PM
It happens to me when I want to save the file as a different file type and that file name already exists, and it's in a different color mode...it adds copy :p. For instance, i change my psd file into an index bmp image. it won't let you choose not to add the word copy.

diffx
02-12-2007, 11:28 AM
Another example (PS CS2):

I have a jpeg in a folder. I open it in ps, delete some parts and hit "Save as" and then choose png. It adds "copy" as long as i save it in the same folder. When i choose a different folder, the "copy" is gone (The "copy" checkbox remains gray at all times).

It's really annoying me: first of all i never want the word copy in my filename, and even if i did, i would like to have the choise to add it myself.

Let's hope Adobe removes this annoying function in CS3.

BlueFlare
02-13-2007, 03:14 AM
Photoshop will always add “copy” if you’re saving a file with the same name in the same folder, but only when you have more than one layer and use a file format that doesn’t support multiple layers.

You can test this yourself with for example Jpeg as format. Change the format to “TIFF” in the pull-down menu and you’ll notice that the word “copy” will disappear again, since TIFF supports multiple layers.

The reason why so many other people never experienced this is because they mostly use (for good reasons) “Save for Web” which not only has more options for optimization and a preview, but it also doesn’t have the “copy” problem.

So why was it added? I think it’s because of the following. Certain formats allow you to save multiple layers, PSD is one of them. It’s also possible to save to PSD without using layers, that’s why there’s an option called layers in the “Save As” window. Turn it off and you’ll notice when you want to save the file with the same name in the same directory that it will add “copy” to the file name, probably as an extra protection on top of the regular “Do you want to replace it?” window that you get when you try to save to the same file.

I think Adobe wanted to make sure that users wouldn’t overwrite huge Photoshop files with hundreds if not thousands of layers file by accident. Personally I think they’ve gone too far. Because let’s face it, in order to overwrite a layered PSD file with a version that is not layered, you have to:

a. save to the same folder
b. give the file the same name
c. unselect the “layers” checkbox
d. ignore the “Do you want to replace” warning window.

That we see the “copy” behavior with Jpeg (and not only Jpeg) seems to me like a bug, since no Jpeg can ever have multiple layers.

Don't forget that some bugs take years for Adobe to solve, that is if they want to solve it. A good example is the famous "invisible cursor" on a 50% gray background, it took years before they were willing to solve it in (CS2).

diffx
02-13-2007, 10:02 AM
Thanks for clearing that up a bit. I was planning to use "save for web" more often anyway so i'll give it a try :)

CGTalk Moderation
02-13-2007, 10:02 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.