PDA

View Full Version : how can i get ambient occlusion to ignore a material/object


T4D
01-19-2007, 10:15 AM
HI all :)

I have ambient occlusion in my shader tree but I want it to ignore one material/object
the object is being used as a render boolean

but AO still works it into it's cal's it even tho it's 100% transparent ?

any ideas ?

bt3d
01-19-2007, 10:32 AM
Is it possible to set your object invisible for the secondary rays in your scene? If so, you can solve your problem by this simple way. The normal AO doesn't work with transparency. Take a look at the BA Shader collections BA_raylength shader. If I remember right it supports transparency.
regards
Tim

T4D
01-19-2007, 10:45 AM
BAM Your the Man :thumbsup:

turning off the secondary rays done the trick :buttrock:

mattmos
01-19-2007, 10:53 AM
If you disable secondary rays on the object you don't want to include in the AO it should remove it. If you need secondary rays for any reason then just create a different pass for the AO, hide the offending objects, and comp it.

T4D
01-19-2007, 11:34 AM
If you disable secondary rays on the object you don't want to include in the AO it should remove it. If you need secondary rays for any reason then just create a different pass for the AO, hide the offending objects, and comp it.

rendering a AO pass on it's own, pretty much doubles my total render time per frame
So i put AO in my RGB pass on a per surface level ( changing the settings on a per surface level )

this has worked for me for afew months,.. but this job needed some render booleans and that changed things alittle,.. But all fine now :thumbsup:

CGTalk Moderation
01-19-2007, 11:34 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.