PDA

View Full Version : How can i decrease the particle display size?


animaxforever
01-10-2007, 06:19 PM
Hi guys,

Here is the screen shot of the particle system of my pc. I've seen some tutorials in which the particles displayed as dots are much more finer in detail & small in size whereas my dots display is bigger in size.

Is it the problem with my graphics card (nvidia geforce 5200) or any settings need to be changed in 3dsmax6.

http://img455.imageshack.us/img455/697/sscm5.jpg
(http://img455.imageshack.us/my.php?image=sscm5.jpg)

PiXeL_MoNKeY
01-10-2007, 07:39 PM
Try changing your viewport driver to Software instead of OpenGL/DirectX.

-Eric

animaxforever
01-10-2007, 07:56 PM
thanx a lot, it worked....

actually i had direct 3d turned on before and i also tested in OpenGl before posting the question but never tried the Software renderer.

Why there are three options (Software, OpenGL and Direct 3d) in viewport options, could please tell me the advantages and disadvantages of that?

thanx again..

Bobo
01-10-2007, 08:56 PM
thanx a lot, it worked....

actually i had direct 3d turned on before and i also tested in OpenGl before posting the question but never tried the Software renderer.

Why there are three options (Software, OpenGL and Direct 3d) in viewport options, could please tell me the advantages and disadvantages of that?

thanx again..

Historical reasons, mainly.

Max 1.0 was developed between 1993 and 1996 - in those days, hardware accelerated cards were either not available, or just coming into the mainstream, OpenGL was just a couple of years old and mainly on SGI machines.
Autodesk had acquired a nice company called Ithaca Software which had a proprietary graphics API called HOOPS and the corresponding device interface was called HOOPS Device Interface or HDI (then called Heidi). It allowed both a rather fast software rasterization and direct support for graphics cards. So when Max 1.0 shipped in 1996, it supported only Software Z-Buffer and custom Heidi drivers for graphics accelerators.

Since these drivers were difficult to develop and thus hard to find, people reqested OpenGL support, so Max 2.0 added that.

Later, when Direct3D became more stable after about 6 releases (while OpenGL was still rock solid in its 1.2 version ;)), support for Direct3D was added but was almost unusable, but since Max R4, Discreet/Autodesk commited to improving only the Direct3D drivers. Since around R6, geometry gets cached on the graphics card memory, so panning and orbiting is very fast.
Now in Max 9, using Direct3D really makes a big difference - the caching system was heavily optimized and made smarter than in 6/7/8. It now only updates the changes you are making as opposed to the whole object, so moving one of a million vertices is really fast. In earlier versions, all million vertices would have been sent to the card again with each move.

If you have a modern graphics card supporting DirectX 9, you should be using that.
If you have problems using Direct3D, use OpenGL. If that does not work, you might have to go to Software mode, but it is going to be really slow in comparison (but is still cool as you can run Max on ANY graphics card, even without any 3D capabilities).

Note that OpenGL and Direct3D support 8 or 16 lights in hardware, while Software Z-Buffer curremtly supports 32 lights in the viewports, but in software (so it is slower). Usually, SZB is the most stable implementation, so if you suspect your graphics drivers to be a cause of trouble, you should switch to that to test...

animaxforever
01-11-2007, 03:49 PM
Thanx Bobo for the reply.

My only problem in Direct 3d and OpenGL was the visual feedback of the particle appearance.I wanted the appearance of the particle to be smaller, which i atlast achieved in Software Z-Buffer.Now, is there any way i can achieve that in Direct 3D or OpenGL as the appearance was the only reason for me to change the viewport settings to SZB not D3d or OGL?

As you said Direct3d is recommended in max 9 and i am using trial version of max9 also now.i am getting the same result in direct 3d(bigger particles).And yes, my graphics card is DX9 supported.

CGTalk Moderation
01-11-2007, 03:49 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.