PDA

View Full Version : passing a light trought a curtain/drapery


d7man2000
12-30-2006, 03:33 PM
In Mental Ray...how can I make so light pases trought a curtain/drapery and still casts a shadow?

I still want to make it look like it is a curtain but without blocking the light.

hominid
12-30-2006, 08:22 PM
No problem, just apply some transparency to your curtain's shader and make sure the light that's casting the shadow is set to ray trace shadows. I just did an image like this, where I used a file (fabric pattern) to drive the transparency channel. Worked like a charm.

Cheers,
Pete

d7man2000
12-30-2006, 09:29 PM
i tried with a fabric, but global illumination didn't allow to cast shadow or go through the material

hominid
12-30-2006, 09:59 PM
I dont know, it worked fine for me. Make sure the fabric texture is driving the transparency channel. Try testing it without the texture first and just setting a value like .5 in the transparency

Pete

d7man2000
12-30-2006, 10:14 PM
ok, thanks,
did you use any particular fabric texture?

hominid
12-30-2006, 10:37 PM
nope just something with an open enough weave so it casted a nice textured shadow.

Pete

yankhr
04-30-2007, 11:04 AM
i tried with a fabric, but global illumination didn't allow to cast shadow or go through the material

Iīm very interested in this issue. I have the same problem with a curtain that should still cast a semi transparent shadow. But with Global Illumination itīs not working. Anyone has a solution for that?
Since many hours I try to get that running. Perhaps one has to use some special MR Shader that let photons passing through...

hakanpersson
04-30-2007, 08:43 PM
/Photon attributes, on a blinn or whatever. There you have "Refractive index", "transparancy" and so forth. Should be a good place to start looking

Als
04-30-2007, 09:11 PM
Use Mia_material!
In manuals check the explanation about the paper, it's very similar setup...
(I hope this is what are you after)

Als

yankhr
05-01-2007, 11:36 AM
Thanks guys for your quick replies!
I didnīt find the mia_material in Maya. Where can I find or get it?
Now I managed to get a semi transparent shadow by putting the DGS Shader and set the transparency to about a half. After that I put a the Shadow Shader on the curtain. And it works. But still the DGS Shader bothers me a bit. Iīm new to Mental Ray but I have the feeling that this DGS isnīt the best and fastest selection in that case.

junkpiler
05-02-2007, 07:27 PM
mia material should be in mentalray tabs in hypershade. It's only in maya 8.5. It has great documentation on it. There are some presets available too to start with, unfortunately there's no preset for an sss-type setting.

another alternative - an old way of doing this: use any maya material (blinn/lambert), turn up the Translucence, and play around with the depth and focus. Make sure your light has raytrace shadow. I've been successful with this method, but the only way i could get soft shadow is by adjusting the raytrace shadow parameter in the light itself (increase light angle a bit and shadow rays to about 16) - which means you will take a hit in the render time.

yankhr
05-04-2007, 02:08 AM
"mia material should be in mentalray tabs in hypershade. It's only in maya 8.5. It has great documentation on it. There are some presets available too to start with, unfortunately there's no preset for an sss-type setting."

Strange, the mia_material is missing. Do I have to load it especially?

I will also try your hint with the normal blinn or lambert material.

junkpiler
05-08-2007, 12:25 AM
as far as i know, mia should be loaded automatically. You can also check inside your \Program Files\Autodesk\Maya8.5\mentalray\include and \lib and see if there is architectural.mi and dll.

mustique
05-08-2007, 02:34 PM
It doesn't work with GI cause photons get blocked. The photons should ignore your curtain material in order to go through. Assign a transmat photon shader in your materials shading group node where it reads: photon material.

Emil3d
05-08-2007, 04:22 PM
Go to MR Render Settings > Caustics and Global Illumination > Photons Tracing, and turn on Direct Illumination Shadow Effects

MasterZap
05-08-2007, 06:52 PM
It doesn't work with GI cause photons get blocked. The photons should ignore your curtain material in order to go through. Assign a transmat photon shader in your materials shading group node where it reads: photon material.

When you use mia_material you should always, always ALWAYS have the same instance of mia_material in your surface, your shadow, and your photon slot.

Only then can the physically correct result be acheived.

/Z

trask
05-08-2007, 09:31 PM
Interesting about instancing the material in the shadow slot. Using DGS materials I always instanced the photon slot, but not the shadow; have to try it out. Does this affect the density and color of the shadow?

I assume the mia_material behaves similair to the dgs material? I've never used Maya.

MasterZap
05-09-2007, 01:05 AM
Interesting about instancing the material in the shadow slot. Using DGS materials I always instanced the photon slot, but not the shadow; have to try it out. Does this affect the density and color of the shadow?

I assume the mia_material behaves similair to the dgs material? I've never used Maya.

DGS doesn't do transparent shadows at all, whereas the mia_material has a very complex shadow shader implementation, including attenuation of shadow rays through the volume of solid glass objects etc.

It is intended to ALWAYS be used in all three slots.

/Z

(Was bold italic underline yellow max fontsize emphasized enough ;) ?)

elvis75k
05-10-2007, 12:33 PM
(Was bold italic underline yellow max fontsize emphasized enough ;) ?)

yes, but when you say ALWAYS, you mean always, or always in gi only? ;)

CGTalk Moderation
05-10-2007, 12:33 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.