PDA

View Full Version : Black Gloss reflections (mental ray)


dmx006
12-11-2006, 01:05 PM
Ive been trying to build a somewhat realistic scene with a gloss black cube for a project Im working on. I am attempting to make the sides a little lighter as at the moment they are simply too black - no matter what I add to the scene I just cannot get it to work!

The top surface works well and reflects the light box sitting above it (thanks to www.jeffpatton.net (http://www.jeffpatton.net) for some superb files, Ive learned a lot!)..

Any advice would be appreciated..
(http://www.david-maxwell.co.uk/cube/cube1.jpg)

gringer
12-12-2006, 01:04 AM
From what I can tell after looking at your picture, is that you need something more in your environment for your cube to reflect. The only reason the top of the cube is lighter is because it is reflecting the white object. Try adding some other geometry around the cube and make them invisible to the camera (right click on object, properties, visible to camera).

Cheers :D

dmx006
12-12-2006, 08:52 AM
From what I can tell after looking at your picture, is that you need something more in your environment for your cube to reflect. The only reason the top of the cube is lighter is because it is reflecting the white object. Try adding some other geometry around the cube and make them invisible to the camera (right click on object, properties, visible to camera).

Cheers :D

didnt realise u could make objects invisible to the camera, very useful! many thanks!

GingerDave
12-13-2006, 02:21 PM
you could also try adding an hdr map to the environment, that will give you pretty cool reflections

some hdr images > http://www.debevec.org/Probes/

dmx006
12-14-2006, 12:24 PM
From what I can tell after looking at your picture, is that you need something more in your environment for your cube to reflect. The only reason the top of the cube is lighter is because it is reflecting the white object. Try adding some other geometry around the cube and make them invisible to the camera (right click on object, properties, visible to camera).


just a quick one.. Ive added some geometry around the cube and made them invisible to the camera as suggested which works well - the only problem being that the geometry still casts shadows (or what looks like a footprint) on the ground surface even though the objects themselves dont render.. Ive tried unticking cast/receive shadows but to no avail..
apologies if this is an annoyingly simple question!

JLBeck
12-14-2006, 07:48 PM
click your light source, and in the drop down menu, there is an exclude option that will let you choose which object(s) will and will not recieve illumination, shadow casting or both. but this also depends on what types of lights u'r using

MikeBracken
12-14-2006, 09:28 PM
Also, you can open the objects properties and tell it not to cast shadows, same as you told it not to be visible to the camera.

CGTalk Moderation
12-14-2006, 09:28 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.