PDA

View Full Version : Rotation data NOT being retained after Keyframing


drfoley
12-03-2006, 02:50 PM
Hopefully this is a simple problem.

I have a character with a whip that I want him to "lash". I started this "lash" cycle with keyframing his beginning right wrist rotation (right wrist Effector) with his arm down at his side. He needs to rotate his wrist as he raises his arm. I then move a few frames forward and raise his arm and rotate his wrist. I then keyframe this. So far so good.

But here's the rub. When I go back to the 1st wrist rotation keyframe the wrist is now rotated the same way as the 2nd keyframe. It's as if I never keyframed it even though I can see a keyframe marker on the timeline.

I've tried doing this on different layers, with and without Auto-key on, in all keying modes: Full body, Body part and Selection without any difference. I did this in Story with 1 main character track set to lower body that I put motion clips on and an Additive Subtrack. I only keyframe on the Subtrack which is set to right arm and left arm. I also tried adding an extra Subtrack just for the right hand but still no difference. And if you think I messed up my character setup I also get the same problem with the Basketball player that comes with MB7. I set Story up the same way for him.

MB7 should be able to do something simple like this. So I must be doing something wrong.

I'm running out of hair to pull. Can someone help me please?

Thanks.

CGTalk Moderation
12-03-2006, 02:50 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.