PDA

View Full Version : Compiling plugin for Maya7 OSX on an intel mac


JackSMillenium
11-18-2006, 08:59 PM
Hi -
I've recently upgraded to a mac book pro. Maya7.0 runs fine, but I'm having difficulty building plugins on the new machine. The devkit xcode projects all fail immedately with the following error:

gcc-3.3: installation problem, cannot exec `cc1plus': No such file or directory

gcc-3.3 (and the corresponding cc1plus) are in fact properly installed, but I'm suspicious that gcc-3.3 doesn't know how to produce code on an intel-based mac.

Has anyone had any success building plugins for Maya7 (or even Maya8 for that matter) on an intel mac ?

Thanks in advance !
Jack.

JackSMillenium
11-18-2006, 09:28 PM
Update: I was able to compile plugins for Maya8 by setting the Architecture in XCode to "ppc" (instead of the default i386). This only works because Maya8 uses g++ 4.0 (instead of 3.3).

I'd still like to be able to build plugins for Maya7 if anyone has any idea ?
Thanks,
Jack.

CGTalk Moderation
11-18-2006, 09:28 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.