PDA

View Full Version : set neutral pose -> rot -> undo = ?


jigsawe
10-30-2006, 01:50 AM
hi.

there is this problem i have. it is that if i rotate an object then set a neutral pose to it, then i rotate on an axis over 360, then undo it, it doesnt go back to zero.

instead it goes back to the nearest value which is the multiple of 360. is there anyways to fix this problem?

i am building a rig, and this is creating serious problems.

thanks

tuna
10-30-2006, 02:18 AM
Yes. This plus the fact that on some rotation orders + neutral poses applied, It's impossible to rotate above 180 degrees using the manipulator (snaps back to -189.9) really bothers me.

The solution I'm using right now is to just ignore neutral pose all together on the controls it effects (like some bones and such), and just set the translations and rotations as 0 by parenting the control to a parent aligned to it. I'd love to know the reason and perhaps a better work around myself.

shadowedge
10-30-2006, 03:44 AM
The solution I'm using right now is to just ignore neutral pose all together on the controls it effects (like some bones and such), and just set the translations and rotations as 0 by parenting the control to a parent aligned to it. I'd love to know the reason and perhaps a better work around myself.

same here.

I try to avoid bone rotations as much as possible. I apply the neutral pose whenever I move parent controllers only. But for bones, why not try the reset bone to preffered rotation command in the create > skeleton panel? :shrug:

CGTalk Moderation
10-30-2006, 03:44 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.